Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2806

Summary: DNS broken: No default nameserver in resolv.conf
Product: [Retired] Red Hat Linux Reporter: warwick
Component: caching-nameserverAssignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-15 20:23:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description warwick 1999-05-14 00:34:24 UTC
Changing from 5.1 to 6.0, with no `nameserver' line in
/etc/resolv.conf for either install, 5.1's DNS defaults to
localhost, but 6.0's just fails. (Lynx, Netscape, ping...)

Add `nameserver 127.0.0.1' to resolv.conf.

resolv.conf isn't owned by any package, but this seems to be
something you'd want if you run a caching nameserver
locally.

Comment 1 warwick 1999-05-14 00:36:59 UTC
Sorry, I said `changing from 5.1 to 6.0'. I meant `observed difference
from 5.1 in a fresh install of 6.0'

Comment 2 Jeff Johnson 1999-05-15 20:23:59 UTC
The installer (and ultimately the user) is responsible for
configuring the DNS client. Assuming that there is a nameserver
running on localhost is not the Right Thing To Do.

------- Email Received From  Tim Baverstock <warwick@sable.demon.co.uk> 05/15/99 18:43 -------