Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 279

Summary: IP masquerader doesn't work properly on high valued ports
Product: [Retired] Red Hat Linux Reporter: ah313
Component: kernelAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-03 19:08:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description ah313 1998-12-03 18:29:25 UTC
When using a FTP client behind a IP masquerader, and
trying to connect to a FTP site that runs on port 41181,
the masquerader doesn't work properly.

Connection is established, but the FTP client just hangs.
IE: you cannot get a directory listing for example, or
do any other operations.  I haven't done extensive testing
to see what other ports it fails on, but I have a feeling
the IP masquerader does not work properly work on any
port beyond 32767 (2^15 - 1).  The machine behind the IP
masquerader was a Win95 running CuteFTP 2.6.  I also tried
the FTP client in the DOS prompt, and identical results.
Therefore I doubt this is a client problem.

Comment 1 Bill Nottingham 1998-12-03 19:08:59 UTC
*** This bug has been marked as a duplicate of 266 ***