Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 277

Summary: trn: Looses list of already read articles
Product: [Retired] Red Hat Linux Reporter: vek
Component: trnAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: aleksey, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-02-02 14:58:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description vek 1998-12-03 17:56:28 UTC
The trn news reader often looses the list of already read
articles.  It occurs after you get a warning that someone
has modified the news group and that it is now assumed that
nothing is read.


Difficult to explain the symptoms, but the problem occurs in
the source file rcln.c around line 81:

The variable morenum is now a 8 bit bool type, but should be
at least 16 bit in orer to hold the result if isdigit()

The result is that the variable morenum is always false, and
that causes the list of read articles to become garbeled.




The problem poped up while reading the comp.os.linux groups
with several thousane articles, and a lot of crossposts
within these groups.  The rpoblem is related to mark all
occurences of a crossposted article as read.




Regards


Villy Kruse

Comment 1 Jay Turner 1998-12-08 20:06:59 UTC
Can you give us more information about any messages that you get when
this deletion occurs.  It sounds as if you are getting caught in the
expire cycle on your newsreader.  Is this a correct statement?

Comment 2 Aleksey Nogin 1998-12-23 03:26:59 UTC
It seems the person who closed the bug did not read the bug e-mail
directory. I believe this bug should be reopened.

Comment 3 vek 1999-01-05 14:16:59 UTC
The problem was not fixed

See my e-mail messages where my full message is to be found.

Villy

Comment 4 Aleksey Nogin 1999-01-06 05:39:59 UTC
This is a duplicate of #587

Comment 5 Jeff Johnson 1999-02-02 14:58:59 UTC
*** This bug has been marked as a duplicate of 587 ***