Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2728

Summary: updatedb (bdflush)
Product: [Retired] Red Hat Linux Reporter: stef.pillaert
Component: findutilsAssignee: David Lawrence <dkl>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-01 19:24:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description stef.pillaert 1999-05-11 07:27:34 UTC
Don't know if this is a bug, but locate acts strange now and
then, so...

I notice that updatedb keeps on running (forever?)
"ps aux" shows:

updatedb(bdflush)

Should there be something excluded in slocate? Or is this
behaviour normal?

Thanks,

Stef.

Comment 1 Bill Nottingham 1999-05-11 14:35:59 UTC
that's update (bdflush), which is the kernel's cache
flushing-daemon. It doesn't have anything to do with
slocate.

Comment 2 stef.pillaert 1999-05-12 07:10:59 UTC
OOPS!! Very sorry!
But the reason I got confused was: running "updatedb" (and not
slocate, sorry) hangs. (and I thought it was launched at startup, and
confused it with update)

Should I exclude something from updatedb?
Thanks.

Stef.

Comment 3 Bill Nottingham 1999-05-13 15:04:59 UTC
If you do 'strace -o output updatedb', and then look at
the output file when it hangs, where is it hanging?

Comment 4 Jeff Johnson 1999-05-15 22:33:59 UTC
*** This bug has been marked as a duplicate of 2682 ***

Comment 5 stef.pillaert 1999-05-17 08:32:59 UTC
Well, it seems to hang when doing "chdir(".automount")". Do you want
me to give you the details given by strace?
Stef.

Comment 6 Jeff Johnson 1999-06-01 19:02:59 UTC
I've replace updatedb in slocate-1.6-1 to more perfectly imitate
the behavior of the findutils updatedb. This means that certain
directories and NFS or smb mount points will not be searched while
building the slocate database.