Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2678

Summary: relaying denied from localhost
Product: [Retired] Red Hat Linux Reporter: jan
Component: sendmailAssignee: Jay Turner <jturner>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-16 23:54:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jan 1999-05-09 01:58:30 UTC
mailhandlers like mh (used in emacs for instance), and exmh,
use sendmail.  In the default configuration of sendmail,
/etc/sendmail.cf should read the database corresponding to
/etc/mail/access and allow relaying of mail from localhost.
/etc/sendmail.cf is not properly configured, so that the
entries in /etc/mail/access are ignored and it is impossible
to send mail using the above mailhandlers.

P.S. reverting to RedHat 5.2's /etc/sendmail.cf and
regenerating ip_allow, name_allow, relay_allow in /etc/mail
is a workaround, but it is perhaps not as secure.

P.P.S. I note that bug 2400 reports the same symptoms.  The
working sendmail.cf is from the rpm 8.8.7-20, the sendmail
rpm in the redhat 6.0 distribution is 8.9.3-10.

Comment 1 Jeff Johnson 1999-05-16 23:54:59 UTC
*** This bug has been marked as a duplicate of 2677 ***