Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2645

Summary: vim in i386 install image is linked against libX11
Product: [Retired] Red Hat Linux Reporter: dfetterly
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-10 14:08:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description dfetterly 1999-05-07 23:29:12 UTC
I ran ldd on a fully installed system to get this output,
the reference to libX11 causes vim to fail when run from the
text console during the install.

 ldd RedHat/instimage/usr/bin/vim
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6
(0x40007000)
        libncurses.so.4 => /usr/lib/libncurses.so.4
(0x400aa000)
        libdb.so.3 => not found
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x400e9000)
        libdl.so.2 => /lib/libdl.so.2 (0x400ef000)
        libm.so.6 => /lib/libm.so.6 (0x400f2000)
        libc.so.6 => /lib/libc.so.6 (0x4010b000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x401b0000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2
(0x2aaaa000)

Comment 1 Bill Nottingham 1999-05-10 14:08:59 UTC
*** This bug has been marked as a duplicate of 2439 ***