Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2613

Summary: segmentation fault
Product: [Retired] Red Hat Linux Reporter: rory
Component: linuxconfAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: rapid_clicker
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-03 22:53:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description rory 1999-05-06 21:29:51 UTC
linuxconf core dumps with a segmentation fault.

System is configured with two ethernet cards and acts as a
DHCP server. After installation of RedHat 6.0, enabling the
second ethernet card, and installing the DHCP rpm, and
rebooting, linuxconf will core dump whenever run. A full
reinstall and following the same steps reproduced the
problem.

Comment 1 rory 1999-05-06 23:02:59 UTC
Further investigation reveals the cause:
DHCPD was manually configured, and did not contain an entry of the
form:
server-identifier xxxxx;
The lack of a "server-identifier" entry causes the segmentation
violation at line 899 of dhcpedit.cc.

Please note that this was not required for previous releases, and may
affect other users who are upgrading.

Also note that if multiple ranges for a subnet are specified, the
linuxconf program will only display the last one of the group. An
example of this would be:

subnet 192.168.1.1 netmask 255.255.255.0 {
    range 192.168.1.10 192.168.1.100;
    range 192.168.1.110 192.168.1.200;
}

which would only display the range 110-200.

-Rory

Comment 2 whampton 1999-05-28 14:31:59 UTC
Linuxconf on a Toshiba 8000 laptop segfaults often, usually
when trying to "accept" a feature during networking setup.
It has segfaulted nearly 10 times as I have setup the RH6.0 laptop.

Comment 3 marc.lefranc 1999-06-03 08:19:59 UTC
linuxconf also segfaults on my machine, even after reinstalling the
package.
1024 # linuxconf
Segmentation fault

Comment 4 Harry Hart 1999-07-23 23:51:59 UTC
linuxconf segfaults when launched, for me, too.  I'm running RHL6.0
(Intel) on a Pentium or PII.  DNS (resolver & BIND), IMAP, and
SendMail are the only network services.

Comment 5 Michael K. Johnson 1999-08-03 22:53:59 UTC
Reported fixed in linuxconf-1.16r1.3, released as update RHEA-1999:026