Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2591

Summary: need summary
Product: [Retired] Red Hat Linux Reporter: xintian
Component: liloAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-11 18:28:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description xintian 1999-05-06 07:32:04 UTC
Lilo seems to have some problems with the "append" command
in /etc/lilo.conf.

The machine has 1GB RAM on board, which causes the kernel
panic. I have to specify "mem=1000m" to the kernel.

When I manually type "linux mem=1000m" at the lilo prompt,
everything works fine. However, if I use the following
/etc/lilo.conf and run lilo to install the loader. The
kernel panic remains as if I've done nothing.

boot=/dev/sda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
append="mem=1000m"
image=/boot/vmlinuz-2.2.5-15smp
        label=linux
        root=/dev/sda2
        initrd=/boot/initrd-2.2.5-15smp.img
        read-only
image=/boot/vmlinuz-2.2.5-15
        label=linux-up
        root=/dev/sda2
        initrd=/boot/initrd-2.2.5-15.img
        read-only

Comment 1 xintian 1999-05-07 00:28:59 UTC
Just let you know, it's working this morning. I am quite confused
at this time. Maybe it's because of my mistake. Sorry.

Comment 2 Michael K. Johnson 1999-05-11 18:28:59 UTC
Unless it happens again, we'll assume that you accidentally
forgot to run lilo after modifying lilo.conf -- something that
has happened to most of us.  :-)