Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2554

Summary: 6.0 Won't serve NFS to solaris or other Linux Boxes?!?
Product: [Retired] Red Hat Linux Reporter: haynal
Component: nfs-serverAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: haynal, osteiner
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: haynal@umbra.ece.ucsb.edu
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-23 05:20:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description haynal 1999-05-05 04:21:14 UTC
We recently upgraded to RedHat 6.0. We have a Dell PowerEdge
2300 Server with dual 400 MHz PIIs. With RedHat 5.2 we had
no problems serving NFS to the Solaris 2.5.1 and other Linux
machines in our lab. Now, none of the Solaris machines will
mount the Linux-served NFS partitions. This error appears:

NFS server not responding, nfs mount: <our linux machine>:
NFS service not responding
nfs mount: retrying: /usr1

Furthermore, the other linux machines are able to mount one
of the NFS partitions as read-opnly. When they mount the
second NFS partitions, they get an additional copy of the
first partition as read only!

These results are with the stock precompiled i686 smp
2.2.5-15smp kernel distributed by RedHat. The same problem
occurs if I recompile the kernel.

Comment 1 Jeff Johnson 1999-05-05 14:50:59 UTC
To use NFS to mount a file system from a Red Hat 6.0 linux server
onto a solaris client, you will need to add the option "vers=2"
to the solaris mount command.

Dunno about the inherited ro on linux yet ...

------- Email Received From  Steve Haynal <haynal@umbra.ece.ucsb.edu> 05/06/99 01:02 -------

Comment 2 Jeff Johnson 1999-06-17 17:47:59 UTC
*** Bug 3535 has been marked as a duplicate of this bug. ***

When I export a filesystem to a SUN system, the SUN system
cannot see it.  Gives this error:

nfs mount: aerialist: NFS service not responding
nfs mount: retrying: /mnt

Also, after doing so, I can't unmount the file system that I
was attempting to export.  I have to shut down the nfs
server and restart it before I can umount.  Strange.I suspect you problem is the same as #2554. If not please reopen.
You might also try knfsd-1.4-1 from Raw Hide which no longer
advertises NFSv3 support.