Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2553

Summary: ytalk doesn't work (hangs)
Product: [Retired] Red Hat Linux Reporter: xp
Component: ytalkAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: chris, rhardy
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-19 22:36:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description xp 1999-05-05 04:02:06 UTC
Problem:
After upgrading from RedHat 5.2 to 6.0, I found that ytalk
would allways hang and would not get any connection

Solution:
Uninstalling the talk package and installing the ntalk
package from RedHat 5.2 cured the problem for me. No changes
were needed to the ytalk package.

Comment 1 rhardy 1999-05-09 09:06:59 UTC
We had the same problem. We solved the problem by doing an rpm -e
ytalk, installing Redhat's SRPM, rebuilding the ytalk rpm with
rpm -bb and installing the new RPM.
Everything seems to work fine now.

Comment 2 rhardy 1999-05-10 20:24:59 UTC
I was incorrect in my previous statement. A recompile has no effect
on the hanging of ytalk. Both in.talkd and in.ntalkd seem to fight
over ytalk connections. Commenting out the in.talkd line and leaving
the in.ntalkd line active makes ytalk behave normally.

Comment 3 rhardy 1999-05-10 20:31:59 UTC
I thought I should reword my previous incomprehensible message...
When a ytalk process hangs, both a in.talkd and in.ntalk can be
observed running on the destination machine. The only way we could
stop ytalk from hanging was to comment out the in.talkd line in
inetd.conf (leaving in.ntalkd active).

Comment 4 Chris Evans 1999-05-14 13:23:59 UTC
I logged a duplicate bug yesterday..

Note that even when you disable in.talkd, and get it working through
in.ntalkd, there is still a bug. When a talk session terminates, the
in.ntalkd process is left hanging around. This also needs fixing.

The severity, "normal" sounds wrong to - the whole talk subsystem is
knadgered which is quite serious :-)

Comment 5 Alan Cox 1999-06-19 22:36:59 UTC
*** This bug has been marked as a duplicate of 2799 ***