Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 241850

Summary: Various Mono deps not available for PPC64
Product: [Fedora] Fedora Reporter: Peter Gordon <peter>
Component: blamAssignee: Alex Lancaster <alexl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: a.badger, alp, dan, gnomeuser, michel, pknirsch, sindrepb
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: ppc64   
OS: Linux   
URL: http://koji.fedoraproject.org/koji/getfile?taskID=21180&name=root.log
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-13 19:53:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 238953    

Description Peter Gordon 2007-05-31 06:03:55 UTC
Blam currently fails to build on PPC64 due to several missing dependencies. As
required for such ExcludeArch inclusions, this bug is to track the resolution of
those and is set to block the PPC64 tracker bug.

The following packages are not available for PPC64:
 * mono-devel
 * gecko-sharp2-devel
 * gnome-sharp-devel
 * dbus-sharp-devel >= 0.60
 * gtk-sharp2-devel
 * gtk-sharp2-gapi

This is when attempting to build 1.8.3-4 (CVS tag blam-1_8_3-4_fc8).

Comment 1 David Nielsen 2007-07-05 17:49:34 UTC
Adding ndesk-dbus to this list, same problem but as a reminder to myself to
build ndesk-dbus on ppc64 once possible.

http://koji.fedoraproject.org/koji/taskinfo?taskID=57121

Comment 2 Bug Zapper 2008-05-14 02:57:34 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Michel Alexandre Salim 2008-07-15 13:34:25 UTC
gnome-keyring-sharp depends on ndesk-dbus, I'm Cc:ing myself as well

Comment 4 Peter Gordon 2008-07-16 00:52:56 UTC
According to the ExclusiveArch of the mono package, it (an thus these
dependencies which would require it) are still not built for PPC64, so I'm
changing the version back to 'Rawhide'.

Comment 5 John Poelstra 2008-09-27 03:21:45 UTC
adding FutureFeature keyword so 'rawhide' version remains at GA of F10

Comment 6 Alp Toker 2008-11-04 10:11:55 UTC
(In reply to comment #1)
> Adding ndesk-dbus to this list, same problem but as a reminder to myself to
> build ndesk-dbus on ppc64 once possible.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=57121

Hi,

ndesk-dbus and ndesk-dbus-glib do not need to be rebuilt for different architectures. A single build works on any architecture -- it's really no different than a perl or shell script.

Comment 7 Alp Toker 2008-11-04 10:18:32 UTC
(In reply to comment #0)
> Blam currently fails to build on PPC64 due to several missing dependencies. As
> required for such ExcludeArch inclusions, this bug is to track the resolution of
> those and is set to block the PPC64 tracker bug.
> 
> The following packages are not available for PPC64:
>  * mono-devel
>  * gecko-sharp2-devel

Note also that gecko-sharp2 is discontinued upstream. blam 1.8.6 and later use webkit-sharp.

Comment 8 Toshio Ernie Kuratomi 2009-04-18 16:42:32 UTC
I've just rebuilt mono for ppc64.  Care to give these another try?