Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 240401

Summary: Typo in /etc/logrotate.d/sa-update
Product: Red Hat Enterprise Linux 5 Reporter: Jose Plans <jplans>
Component: spamassassinAssignee: Warren Togami <wtogami>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: benny+bugzilla, bojan, bugzilla, djuran, dmobrien_2001, gavinflower, hongjiu.lu, ian, igeorgex, jm, musuruan, parkerm, perl-devel, reg+redhat, rollercow, tom, tuju, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-17 14:07:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 223753    
Bug Blocks:    
Attachments:
Description Flags
sa-update.logrotate.patch none

Description Jose Plans 2007-05-17 09:55:16 UTC
+++ This bug was initially created as a clone of Bug #223753 +++

Description of problem:
logrotate error message:

error: sa-update:3 unknown option 'notifyempty' -- ignoring line

Version-Release number of selected component (if applicable):
spamassassin-3.1.7-4.fc6

Fix:
Something like this:

/var/log/sa-update.log {
    monthly
-   notifyempty
+   notifempty
    missingok
}

-- Additional comment from wtogami@redhat.com on 2007-01-23 10:49 EST --
*** Bug 223972 has been marked as a duplicate of this bug. ***

-- Additional comment from _@sucs.org on 2007-01-24 04:04 EST --
This applies to FC5 as well.

-- Additional comment from joshua@iwsp.com on 2007-01-24 11:31 EST --
I get nightly email about this... apply that patch and push the fix!!

-- Additional comment from wtogami@redhat.com on 2007-01-24 15:33 EST --
spamassassin-3.1.7-5.fcX will be pushed soon to solve this issue.


-- Additional comment from wtogami@redhat.com on 2007-01-24 15:33 EST --
*** Bug 224179 has been marked as a duplicate of this bug. ***

-- Additional comment from paul@city-fan.org on 2007-01-26 05:42 EST --
*** Bug 224547 has been marked as a duplicate of this bug. ***

-- Additional comment from wtogami@redhat.com on 2007-01-28 00:05 EST --
This is now fixed in FC5 and FC6 updates.

-- Additional comment from paul@city-fan.org on 2007-01-29 07:40 EST --
*** Bug 225144 has been marked as a duplicate of this bug. ***

-- Additional comment from paul@city-fan.org on 2007-01-29 08:13 EST --
*** Bug 225039 has been marked as a duplicate of this bug. ***

Comment 1 Jose Plans 2007-05-17 09:55:16 UTC
Created attachment 154902 [details]
sa-update.logrotate.patch

Comment 2 Warren Togami 2007-05-17 14:07:40 UTC
This was fixed in RHEL5 day-0 security errata long ago.
spamassassin-3.1.8-2.el5