Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 2400

Summary: unable to send mail using nmh
Product: [Retired] Red Hat Linux Reporter: david.ogilvie
Component: nmhAssignee: Jay Turner <jturner>
Status: CLOSED WORKSFORME QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0CC: aleksey, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-15 19:26:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description david.ogilvie 1999-04-28 19:31:20 UTC
I normally use exmh, and when I try to send mail it now
fails.  I've tried using the comp program in nmh, and that
fails as well, proving that exmh is not the problem. From
the whatnow prompt, the error message is:

What now? send
  david.ogilvie at yale.edu: loses; [USER] 550
<david.ogilvie@yale.edu>... Relaying denied
post: 1 addressee undeliverable
send: message not delivered to anyone

The file /var/log/maillog shows the following (excuse the
linebreaking):
Apr 28 15:28:38 grendel sendmail[3512]: PAA03512:
ruleset=check_rcpt, arg1=<david.ogilvie@yale.edu>,
relay=IDENT:dbo@localhost [127.0.0.1], reject=550
<david.ogilvie@yale.edu>... Relaying denied
Apr 28 15:28:38 grendel sendmail[3512]: PAA03512:
from=<dbo@grendel.td.yale.edu>
, size=0, class=0, pri=0, nrcpts=0, proto=ESMTP,
relay=IDENT:dbo@localhost [127.
0.0.1]

It's entirely possible that the problem is actually in the
sendmail configuration.  Something's clearly busted though.
Btw, I created a new user and tried this from the new
account, and the same stuff happened.  So it's not some
funky thing I did to exmh in the past.

Comment 1 Aleksey Nogin 1999-05-04 05:21:59 UTC
I have not installed 6.0 yet, but from your description it definitely
looks like a misconfigured sendmail. You should try to configure your
sendmail to accept relaying at least from localhost. In 5.2 the
relevant configuration files were in /etc/mail directory

Comment 2 david.ogilvie 1999-05-05 17:43:59 UTC
Forced a reinstall of sendmail, and everything works now.  Odd,
because I swear I tryed that before.  Guess I should have done a
rpm -V.  Sorry for the bug report, and thanks for a great
distribution.

Comment 3 Jeff Johnson 1999-05-15 19:26:59 UTC
This sounds like it has been resolved. Please reopen if not.