Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 239078

Summary: need to %ifarch some subpackages
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: graphvizAssignee: Jima <jima>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: john.ellson, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-22 01:39:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 238950, 239077    
Bug Blocks: 238953, 239132    

Description Bill Nottingham 2007-05-04 19:21:10 UTC
Description of problem:

Neither mono (bug 238950) nor ocaml (bug 239077) can exist on ppc64. Ergo, these
subpackages need %ifarched.

Version-Release number of selected component (if applicable):

graphviz-2.12-6.fc7

How reproducible:

Every time

Steps to Reproduce:
1. Try to build.
2.
3. Profit!
  
Actual results:

Oops, no mono or caml. Build fails.

Additional info:

Comment 1 David Woodhouse 2007-05-04 20:22:37 UTC
The Gentoo folks seem to have ppc64 support for ocaml.

Comment 2 Jima 2007-05-06 02:38:27 UTC
As David knows, there's an ongoing effort (with his help) to get ocaml working
on ppc64.  I'm not aware of a similar effort for mono, unfortunately.  As a
result, I've disabled the -ocaml and -sharp subpackages, and built 2.12-7.fc7,
which I've requested RelEng include in Fedora 7.  I'll happily re-enable -ocaml
(and -sharp) if/when the BRs are available for ppc64.

I'll update this bug when I hear a final word from RelEng.

Comment 3 Jeremy Katz 2007-05-22 01:39:30 UTC
This got tagged