Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236825

Summary: invalid map value 0 from ata-piix. Finds CD drive, but not disks.
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: mkinitrdAssignee: Peter Jones <pjones>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: alan, cebbert, davej, dcantrell, jarod, pjones
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-21 22:26:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226, 172490    

Description Jesse Keating 2007-04-17 20:30:26 UTC
During boot up only the CD is detected, the disk isn't.

See http://people.redhat.com/pjones/img_0501.jpg

Comment 1 Jesse Keating 2007-04-17 20:39:31 UTC
Machine is an intel mac mini core solo.  Will get lspci momentarily.

Comment 2 Jesse Keating 2007-04-23 19:08:39 UTC
Hrm, I'm away from my desk this week, what information do you need?  I'll have
somebody fire it up and look at it.

Comment 3 Dave Jones 2007-04-23 19:37:51 UTC
you mentioned lspci :)

Comment 4 Jesse Keating 2007-04-23 20:05:24 UTC
Well yeah, but i wasn't sure that was actually needed.  I'll try to get somebody
to do that.

Comment 5 Jarod Wilson 2007-04-23 20:41:46 UTC
Well, kernel 2.6.20-1.3094.fc7 has no such problems, it sees the hard disk in
this very same mini without a problem.

Comment 6 Dave Jones 2007-04-23 20:51:19 UTC
spooky.   must have been a side-effect of the recent ATA hpa fixes. (though this
device doesn't have a HPA).


Comment 7 Jarod Wilson 2007-04-24 14:03:04 UTC
We still have problems once we try to boot this kernel (3094) off the installed
system. The installer has no issues, but the initrd falls over, the last few
messages being about not finding any logical volumes and failing to mount
/dev/root. Seems we've made mkinitrd unhappy somehow...

Comment 8 Jarod Wilson 2007-04-24 14:32:59 UTC
Got it booting. Seems to be a timing issue. Inserting a 10-second delay into the
initrd managed to do the trick -- scsi_wait_scan alone isn't cutting it here. :(

Comment 9 Jeremy Katz 2007-05-21 22:25:06 UTC
Weren't you installing and booting off of this box today?

Comment 10 Jesse Keating 2007-05-21 22:26:16 UTC
Yeah, thought I closed this bug, whoops.