Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236782

Summary: hard disk is required but you could be just using a liveCD
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Jenner <mjenner>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: opensource, petersen, tcallawa, virt-maint, wtogami, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-14 15:34:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeremy Katz 2007-04-17 17:02:55 UTC
For the case of something like a live CD, it seems like you want to be able to
specify a VM without a hard drive attached to it.  This is especially painful as
you have to go through and recreate the VM every time you want to restart the
live CD -- after the first start, you're kicked over to boot from hard drive
instead of from the CD.

Comment 1 Mark McLoughlin 2007-05-02 12:28:33 UTC
Some first cut patches for LiveCD support here:

  http://www.redhat.com/archives/et-mgmt-tools/2007-May/thread.html#00010

Comment 2 Red Hat Bugzilla 2007-07-25 02:08:25 UTC
change QA contact

Comment 3 Warren Togami 2007-10-18 15:15:12 UTC
Really two parts to this:
1) No way to boot from CD after initial install (GUI issue)
2) You want to not be required to choose a hard drive.

I was told by #kvm that a hard drive isn't required by qemu.  It *could* be set
to /dev/null (if virt-manager didn't reject it).


Comment 4 Fabien 2008-03-31 18:16:25 UTC
Me too, i need to boot from CD after initial install with GUI. 

This is because screen just before the first start don't let to use several hard
drives.

I my case two solutions :
- during initial vm creation screen, to be able to have several hard drives.
- after vm is created, to be able to boot from CDROM.

Comment 5 Bug Zapper 2008-05-14 02:46:16 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Cole Robinson 2009-03-10 01:33:11 UTC
The pending virt-manager release has a completely redesigned 'New VM' wizard. Details here:

http://blog.wikichoon.com/2009/02/virt-manager-in-fedora-11-new-vm-wizard.html

One of the new pieces is the option to skip specifying storage. If CD/ISO media is used for the install, and no storage is selected, livecd behavior is implied (always boot off CD).

This definitely won't ever be backported to F9: these changes rock the boat a bit too much. Moving this bug to F10 (which is a likely eventual target).

Comment 8 Cole Robinson 2009-09-14 15:34:28 UTC
I think it's too late to be backporting a major virt-manager version to F10, so this bug won't be fixed.

Moving to F11 and closing as CURRENTRELEASE.