Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236725

Summary: ping does not work for subsecond intervals for ordinary user
Product: [Fedora] Fedora Reporter: Tomasz Kepczynski <tomek>
Component: iputilsAssignee: Martin Bacovsky <mbacovsk>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jirislaby
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-07 10:59:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomasz Kepczynski 2007-04-17 12:41:06 UTC
Description of problem:

Selfexplanatory:

gklab-59-001:~/rpmbuild/SOURCES> ping -i 0.3 localhost
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
ping: cannot flood; minimal interval, allowed for user, is 200ms

Version-Release number of selected component (if applicable):
iputils-20070202-3.fc6.i386

How reproducible:
Always for normal user, never for root (but I strongly
suspect that interval in such a case is set to either 0 or 1000ms).


Steps to Reproduce:
See above
  
Actual results:
ping does not allow subsecond intervals for normal users

Expected results:
ping allows subsecond intervals longer then 200ms
for normal users

Additional info:
iputils-20020927-18.EL4.3.i386 as distributed in CentOS 4.4
works OK.

Comment 1 Tomasz Kepczynski 2007-04-17 12:54:13 UTC
The important thing I've just found out: locale. The problem
exists in pl_PL.UTF-8 locale but not in C or en_US. I guess
the decimal separator is the important part here.
common_options hast something like that:
        case 'i':               /* wait between sending packets */
        {
                if (strchr(optarg, '.')) {
                        float t;
                        int r;

while '.' above in strchr should probably be taken from locale
settings.


Comment 2 Jiri Slaby 2007-06-13 20:21:58 UTC
*** Bug 239297 has been marked as a duplicate of this bug. ***

Comment 3 Martin Bacovsky 2007-08-07 10:59:58 UTC
This issue should be fixed in RAWHIDE (iputils-20070202-4.fc8)