Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236513

Summary: bootloader install on unknown platform wipes entire hard drive.
Product: [Fedora] Fedora Reporter: David Woodhouse <dwmw2>
Component: bootyAssignee: Peter Jones <pjones>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-01 14:31:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235611    
Attachments:
Description Flags
patch none

Description David Woodhouse 2007-04-15 19:29:21 UTC
After an install on PS3, booty set up mkofboot to reformat the entire /dev/sda
drive as HFS. This is a little suboptimal, since it wiped away all the
partitions it'd just installed to.

Better behaviour on an unknown platform would be to do what we currently do for
Pegasos -- just leave a copy of yaboot in /boot/etc/yaboot and pray.

Comment 1 David Woodhouse 2007-04-15 19:29:22 UTC
Created attachment 152654 [details]
patch