Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236445

Summary: hplip: scriptlet test wrong?
Product: [Fedora] Fedora Reporter: Bernard Johnson <bjohnson>
Component: hplipAssignee: Tim Waugh <twaugh>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.7.2-3.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-19 08:25:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 207681    

Description Bernard Johnson 2007-04-14 07:48:48 UTC
Description of problem:
When I upgraded from hplip-1.6 series to hplip-1.7.2-2.fc6 in updates-testing, I
tried to fax to test against bugs I filed.  The fax gui completely locked up
everytime within a matter of seconds (no useful info in debug).  I restarted the
hplip daemons and then everything worked ok.

When I look at the spec file, I see:

%post
/sbin/chkconfig --add hplip || :
if [ "$1" == "1" ]; then
  /sbin/service hplip condrestart >/dev/null 2>&1 || :
fi
exit 0

But when I look at
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-ac070867bcfda441b0ae7690be90ac16b43894e8
it appears that the test should be against "2" for upgrade.  This might explain
why I had problems on the upgrade.

As a total aside, you also need a:
Requires(post): /sbin/service
Requires(post): /sbin/chkconfig
Requires(preun): /sbin/service
Requires(preun): /sbin/chkconfig

I also just noticed that:
/usr/lib/cups/backend/hp
/usr/lib/cups/backend/hpfax
is not going to make rpmlint very happy.  You probably want to replace /usr/lib
with %{_libdir} when you get a chance.

Sorry for all the bugs recently, I've been using hplip a lot in the last two
months (tax season - scanning/faxing) and seem to have uncovered every bug :)

Version-Release number of selected component (if applicable):
hplip-1.7.2-2.fc6

Comment 1 Tim Waugh 2007-04-16 09:34:24 UTC
Good catch for the condrestart scriptlet -- fixed in CVS.  I've also added the
requires(post/preun) bits.

The /usr/lib/cups paths are intentionally *not* using libdir, since the
CUPS_SERVERBIN path is /usr/lib/cups on all architectures.  I've added a comment
above those two lines to say that.

Don't apologise for reporting bugs; you're helping to make the software better
for everyone. :-)

Comment 2 Fedora Update System 2007-04-18 22:35:44 UTC
Fixed in update: hplip-1.7.2-3.fc6