Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236360

Summary: gendiff should use -p
Product: [Fedora] Fedora Reporter: Christopher Aillon <caillon>
Component: rpmAssignee: Paul Nasrat <pnasrat>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-16 11:40:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Christopher Aillon 2007-04-13 13:14:33 UTC
Can we make gendiff use -p as well as -u?  It would include some additional
information about where in the original file the patch is being made which will
help tons when updating patches made with gendiff (because of a rebase and
needing to remerge the patch).  While it's touted as including the "C function"
it doesn't hurt to use on other types of files.

Comment 1 Jeff Johnson 2007-04-14 02:19:37 UTC
gendiff already uses -p, at least in rpm-4.4.9:

...

: ${DIFF:=diff -p}

...

UPSTREAM

Comment 2 Paul Nasrat 2007-04-16 11:40:54 UTC

*** This bug has been marked as a duplicate of 146981 ***