Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236174

Summary: RFE: Include Sun's Java 1.6.0
Product: [Fedora] Fedora Reporter: Julius B. <julius.bullinger+rhbz>
Component: java-1.5.0-gcjAssignee: Thomas Fitzsimmons <fitzsim>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-12 16:04:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Julius B. 2007-04-12 10:52:20 UTC
Description of problem:
Since Sun released Java 1.6 ("Mustang") under the GPL would it be possible to
ship Fedora 7 with JRE 6? The newest Version is "Java Runtime Environment
Version 6 Update 1": http://www.java.com/en/download/linux_manual.jsp

Additional info:
I don't really know enough about the opening of Java and whether it happened
already.
I found the source code of JDK 6 on http://download.java.net/jdk6/ , but i don't
know anything about the JRE.

Sorry if this request has been discussed already

Comment 1 Thomas Fitzsimmons 2007-04-12 16:04:13 UTC
Java has not been GPL'd in its entirety yet.  My understanding is that Java 1.7
will be released under the GPL first, with Java 1.6 to follow.  I'll be
proposing the first GPL'd Java release for inclusion in Fedora as soon as
possible after it is released.  For now, closing this WONTFIX, since Java 1.6 is
not GPL'd yet.