Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236103

Summary: zd_chip_control_leds error -110
Product: [Fedora] Fedora Reporter: ericm24x7
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: cebbert, davej
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-25 16:53:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description ericm24x7 2007-04-11 22:31:10 UTC
Description of problem:
Athough the wireless device remain functional at all times, the dmesg outputs
keep displaying the following error messages every a couple of minutes:

Apr 11 18:07:01 fiji3 kernel: zd1211rw_mac80211 2-4:1.0: zd_chip_control_leds
error -110
Apr 11 18:08:57 fiji3 kernel: zd1211rw_mac80211 2-4:1.0: zd_chip_control_leds
error -110

Version-Release number of selected component (if applicable):
kernel 2.6.20-1.3056.fc7.x86_64
wireless-tools 1:28-1.fc6

How reproducible:
Persistent

Steps to Reproduce:
1. download and install zd1211 firmware
   wget
http://kwizart.free.fr/fedora/6/testing/zd1211-firmware/zd1211-firmware-1.3-4.kwizart.fc6.noarch.rpm
   rpm -ivh zd1211-firmware*rpm 
2. bring down the old driver zd1211rw and load only zd1211rw_mac80211
   lsmod|grep zd1211
   modprobe -r zd1211rw
   modprobe -r zd1211rw_mac80211
   modprobe zd1211rw_mac80211
3. Tested under WPA so turn it on if possible
4. run "rsync" to test network transfer.
5. run "dmesg"
  
Actual results:
dmesg output will display the following messages every couple of minutes:
Apr 11 18:07:01 fiji3 kernel: zd1211rw_mac80211 2-4:1.0: zd_chip_control_leds
error -110
Apr 11 18:08:57 fiji3 kernel: zd1211rw_mac80211 2-4:1.0: zd_chip_control_leds
error -110

Expected results:

Comment 1 John W. Linville 2007-04-18 18:01:31 UTC
Odd...looks like the USB accesses for controlling LEDs are timing-out 
occassionally, probably under heavy traffic.  Perhaps there is some missing 
synchronization in the driver...

Comment 2 John W. Linville 2007-04-19 21:52:29 UTC
Please try to recreate this problem using kernel-2.6.20-1.3096.fc7 or later 
(should be available by sometime on 4/20).  Does the problem persist?

Comment 3 ericm24x7 2007-04-19 23:10:59 UTC
I will test as soon as the kernel 3096 build as soon as it reach my mirror.
Right now it doesn't affect the basic functionalities (rsyncing and web
browsing) that much and the LED seems to work OK. 

The effective speed right now is a little slow though: ~800 Kbyte/sec
(6.4Mbit/sec). Since manual rate adjustment (iwconfig wlan0 rate 48M) is not
functional yet, I will worry about that later. The softmac driver usually have
the above rate when it is set manually to 54M, but tend to increase better
(~2000 Kbyte/sec) when set to 36M or 48M.

Comment 4 ericm24x7 2007-04-25 16:53:18 UTC
Just tested 3104.fc7. I agree that the problem only show up when using under
heavy load; since it only show up when I'm running "rsync" program. It doesn't
show up when browsing the internet only. 

I will closed this now since it doesn't appear to affect basic and critical
functions.