Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 236047

Summary: system-config-bind crashes whenever 'manual' is selected from the 'help' menu
Product: [Fedora] Fedora Reporter: Tim W. <weeglos>
Component: system-config-bindAssignee: Ondrej Dvoracek <odvorace>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-30 12:44:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Bug Buddy's bug report
none
Proposed patch none

Description Tim W. 2007-04-11 17:50:21 UTC
Description of problem:
Whenever I select 'manual' from the help menu, the application crashes.

Version-Release number of selected component (if applicable):
$ rpm -qa system-config-bind
system-config-bind-4.0.1-2.fc6


How reproducible:


Steps to Reproduce:
1.  Using an X session, remotely connect (via ssh) to the server as root
2.  Run 'system-config-bind'
3.  Click 'help' then 'manual'
4.  Watch system-config-bind crash and burn
  
Actual results:
system-config-bind crashes.  From the command line:
The program 'bindconf' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadIDChoice (invalid resource ID chosen for this connection)'.


Expected results:
I expected to see the help manual

Additional info:
See Bug Buddy's report (attached)

Comment 1 Tim W. 2007-04-11 17:50:21 UTC
Created attachment 152301 [details]
Bug Buddy's bug report

Comment 2 Tim W. 2007-04-11 18:00:03 UTC
I tried to reproduce the error at the console on the server, but when I
performed the steps to reproduce the problem, the manual just didn't show up --
the application did not crash.

Comment 3 Ondrej Dvoracek 2007-05-30 12:44:02 UTC
Created attachment 155672 [details]
Proposed patch

This patch checks child processes when opening Manual/ISC ARM.