Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 235782

Summary: scim-bridge breaks htmlview, gvim, evolution.
Product: [Fedora] Fedora Reporter: Gilboa Davara <gilboad>
Component: scim-bridgeAssignee: Jens Petersen <petersen>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-15 23:21:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gilboa Davara 2007-04-10 05:39:56 UTC
Description of problem:
Starting evolution, gvim, htmlview or firefox directly under KDE/rawhide all 
fail generating scim_bridge errors.

Version-Release number of selected component (if applicable):
$ rpm -qa | egrep -e 'scim|evolution|htmlview|vim' | sort
beagle-evolution-0.2.16.2-4.fc7.x86_64
evolution-2.10.0-9.fc7.i386
evolution-2.10.0-9.fc7.x86_64
evolution-data-server-1.10.0-5.fc7.i386
evolution-data-server-1.10.0-5.fc7.x86_64
evolution-data-server-1.10.0-6.fc7.i386
evolution-data-server-1.10.0-6.fc7.x86_64
evolution-sharp-0.12.2-2.fc7.x86_64
evolution-webcal-2.10.0-1.fc7.x86_64
htmlview-3.0.0-15.fc7.noarch
scim-1.4.5-11.fc7.x86_64
scim-anthy-1.2.2-3.fc7.x86_64
scim-bridge-0.4.10-1.fc7.x86_64
scim-bridge-gtk-0.4.10-1.fc7.i386
scim-bridge-gtk-0.4.10-1.fc7.x86_64
scim-chewing-0.3.1-9.fc7.x86_64
scim-hangul-0.3.1-1.fc7.x86_64
scim-libs-1.4.5-11.fc7.i386
scim-libs-1.4.5-11.fc7.x86_64
scim-libs-1.4.5-12.fc7.i386
scim-libs-1.4.5-12.fc7.x86_64
scim-m17n-0.2.1-1.fc7.x86_64
scim-pinyin-0.5.91-16.fc7.x86_64
scim-sinhala-0.2.0-2.fc6.x86_64
scim-tables-0.5.7-2.fc7.x86_64
vim-common-7.0.224-1.fc7.x86_64
vim-enhanced-7.0.224-1.fc7.x86_64
vim-minimal-7.0.224-1.fc7.x86_64
vim-X11-7.0.224-1.fc7.x86_64


How reproducible:
Always

Console log:
$ htmlview
ERROR: The browser  does not exist.  Please reconfigure.

Then a dialog box:

"Failed to contact configuration server; some possible causes are that you 
need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to 
a system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)"

... In the mean time, in the console:

Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to allocate the agent. Exitting...
Failed to invoking the agent: No such file or directory
Cannot launch the agent
The messenger is now down
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to allocate the agent. Exitting...
Failed to invoking the agent: No such file or directory
Cannot launch the agent
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()

And when I close the dialog box:

The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down

- Gilboa

Comment 1 Jens Petersen 2007-04-11 03:56:11 UTC
Do it work better if you uninstall scim-bridge-gtk and restart the desktop?

Comment 2 Jens Petersen 2007-04-11 04:22:04 UTC
> $ htmlview
:
> "Failed to contact configuration server; some possible causes are that you 
> need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to 
> a system crash. See http://www.gnome.org/projects/gconf/ for information. 
> (Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
> no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
> not opened successfully, no gconfd located: Permission denied)

scim does not use gconf, so this looks a bit suspicious.

Comment 3 Gilboa Davara 2007-04-14 06:26:21 UTC
It's seems that both GNOME are KDE are completely broken... Removing
scim-bridge-gtk doesn't change anything.
Attempting to delete .gconf* in my home directory.

- Gilboa


Comment 4 Gilboa Davara 2007-04-14 16:40:16 UTC
... I may have a broken rawhide install on my hands. (Due to vmware crapping out
on 2.6.19+ kernels).
I'll reinstall, and try again.

- Gilboa

Comment 5 Jens Petersen 2007-04-15 23:21:04 UTC
Ok, closing for now.