Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 235773

Summary: RFE: beagle should index yum metadata to suggest applications to install based on search keywords
Product: [Fedora] Fedora Reporter: Michael Wiktowy <michael.wiktowy>
Component: gnome-shellAssignee: Adel Gadllah <adel.gadllah>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: maxamillion, otaylor, samkraju, walters
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-05 14:58:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Wiktowy 2007-04-10 05:19:08 UTC
Description of problem:
Just a suggestion based on the instincts of a new user to Linux. When they
wanted to find a program to install, they used the desktop search capability.
They failed and had to find the appropriate program.

However, I thought that this would be a brilliant feature that seemed within
easy reach of beagle. It could be taught both yum and apt metadata caches and
how to launch an installer to add the package to the system when an appropriate
one is found.

Comment 1 Jon Stanley 2008-04-23 20:30:15 UTC
Adding FutureFeature keyword to RFE's.

Comment 2 John Poelstra 2008-08-12 04:19:31 UTC
David what are your thoughts on this feature?

Comment 3 David Nielsen 2008-08-12 06:30:18 UTC
I like the idea, it should be possible to let PackageKit feed beagle the information so it wouldn't be tied to any specific package manager, which might make it easier for upstream to justify implementing.

Another thought is why, when I am no longer the Beagle maintainer (Adel is your master now - and a damn good one I might add), are all the bugs still assigned to me - it seems like a bug.

Comment 4 Michael Wiktowy 2010-11-15 15:13:45 UTC
Since Beagle is all but abandoned in Fedora, any thoughts on adding this to Gnome Shell/Gnome Do/Tracker?

I see this feature has already been added to the Unity Desktop search in Ubuntu.

Comment 5 Michael Wiktowy 2013-11-02 05:28:07 UTC
Looks like some motion in the right direction.
https://bugzilla.gnome.org/show_bug.cgi?id=707594

Comment 6 Ryan Lerch 2014-12-05 14:58:19 UTC
GNOME software now includes a search provider, so uninstalled applications that match the search in the overview are now displayed when searching.