Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 235691

Summary: yum-utils crashes with --oldkernels
Product: [Fedora] Fedora Reporter: Need Real Name <lsof>
Component: yum-utilsAssignee: Seth Vidal <skvidal>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: swarren, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-12-07 04:29:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2007-04-09 16:57:16 UTC
# /usr/bin/package-cleanup --oldkernels
Setting up yum
I will remove the following 8 kernel related packages:
kernel-2.6.19-1.2911.6.5.fc6
kernel-2.6.19-1.2911.6.4.fc6
kernel-2.6.19-1.2911.fc6
kernel-2.6.19-1.2895.fc6
kernel-devel-2.6.19-1.2911.6.5.fc6
kernel-devel-2.6.19-1.2911.6.4.fc6
kernel-devel-2.6.19-1.2911.fc6
kernel-devel-2.6.19-1.2895.fc6
Is this ok [y/N]: y
/usr/bin/package-cleanup:312: DeprecationWarning: returnHeaderByTuple() will go
away in a future version of Yum.

  hdr = my.rpmdb.returnHeaderByTuple(kernel)[0]
Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 402, in ?
    main()
  File "/usr/bin/package-cleanup", line 371, in main
    removeKernels(my, opts.kernelcount, opts.confirmed, opts.keepdevel)
  File "/usr/bin/package-cleanup", line 317, in removeKernels
    my.populateTs()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 171, in populateTs
    self.ts.addErase(txmbr.po.idx)
AttributeError: 'YumInstalledPackage' object has no attribute 'idx'

Comment 1 Stephen Warren 2007-08-08 02:43:33 UTC
This is a bit of a bummer, because this URL says to run this command:

http://fedoraproject.org/wiki/YumUpgradeFaq

Now, since the command failed, I have no idea if it will affect the proper
operation of the rest of the page...


Comment 2 Seth Vidal 2007-12-07 04:29:33 UTC
This is fixed in upstream yum-utils. It should be out in a release shortly.

closing  as upstream.

thank you!