Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 235154

Summary: Firstboot reconfig mode does not work
Product: [Fedora] Fedora Reporter: Hassan Aurag <hassan.aurag>
Component: firstbootAssignee: Chris Lumens <clumens>
Status: CLOSED WONTFIX QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-04 13:45:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hassan Aurag 2007-04-04 02:59:19 UTC
Description of problem:
Reconfig mode does not work at all.

Version-Release number of selected component (if applicable):
1.4.6-1

How reproducible:
All the time.Either boot and pass on reconfig or touch '/etc/reconfigSys' and
reboot.

Steps to Reproduce:
1. Boot and at grub prompt pass on reconfig or
2. touch /etc/reconfigSys and reboot

  
Actual results:
Nothing happens

Expected results:
Firstboot reconfiguration starts

Additional info:
This is fixed in fc6 package 1.4.23-1. I diffed the packages and found some
differences, notably in the mayRun function etc... But there are also other
fixes such as potential crashes (no vbox etc...).

 My question is really can I just copy the rpm files for firstboot from fc6 to
fc5? We are shipping systems and would like the customer to be able to reconfig
their system.

Comment 1 Chris Lumens 2007-04-04 13:45:36 UTC
I don't know that you are going to be able to use the FC6 firstboot RPM on FC5
as-is due to the rhpxl (1.4.8) and system-config-soundcard (1.4.16) changes. 
Try it and see.  If you have the ability to distribute a patched package, you
can just isolate the patch that fixes the reconfig issue.  That was the only
thing fixed in 1.4.10.