Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 235076

Summary: Autotools not running configuration from configuration src directory specified
Product: [Fedora] Fedora Reporter: Jeff Johnston <jjohnstn>
Component: eclipse-cdtAssignee: Jeff Johnston <jjohnstn>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-04 22:59:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Johnston 2007-04-03 18:12:06 UTC
When a project has a directory structure such that configuration is not to be
run out of the top-level directory, the Autotools configuration is not honoring
the src directory specified in the configuration options.  This applies to
configure, autogen.sh, and Makefile.cvs configuration.

Comment 1 Jeff Johnston 2007-04-04 22:59:18 UTC
Bug has been fixed.  Makefile generation was finding the files using the src
directory but was not using it when it came time to run.  A new test has been
added to the testsuite.