Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234688

Summary: Adds bloaty perl dependency
Product: [Fedora] Fedora Reporter: Enrico Scholz <rh-bugzilla>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: dhcp-3.0.5-4.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-11 16:53:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Enrico Scholz 2007-03-31 10:53:14 UTC
Description of problem:

Updated dhcp packages ship a '/usr/share/doc/dhcp-3.0.5/contrib' directory which adds bloaty perl dependencies. Since there are doc files only, they should be marked as non-executable.

| $ rpm -q --filerequire dhcp | grep perl
| /usr/share/doc/dhcp-3.0.5/contrib/3.0b1-lease-convert   /usr/bin/perl perl >= 0:5.004 perl(strict) 
| /usr/share/doc/dhcp-3.0.5/contrib/ms2isc/Registry.pm    perl(strict) 

Alternatively, this directory can be removed or moved into an own 'dhcp-bloaty-perl-scripts' subpackage.


Version-Release number of selected component (if applicable):

dhcp-3.0.5-3.fc6

Comment 1 David Cantrell 2007-04-01 15:57:18 UTC
I took care of Registry.pm requiring the perl-Win32 module, but find-requires
appears to take any file ending with .pm as a Perl file and adds the
perl(strict) requirement.

I completely looked over the 3.0b1-lease-convert script, so I've fixed that.

No Perl requirements now in dhcp-3.0.5-4.fc6.  It'll be in updates-testing for
FC-6.  Post here if it works for you and then I'll move it to final updates.

Thanks for the report.

Comment 2 Fedora Update System 2007-04-02 16:20:48 UTC
dhcp-3.0.5-4.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 3 Fedora Update System 2007-04-09 19:16:58 UTC
dhcp-3.0.5-4.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.