Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234686

Summary: Installer crashes when applying changes to partition layout
Product: [Fedora] Fedora Reporter: FRLinux <frlinux>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: cebbert, davej, mattdm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-19 22:01:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
anaconda dump of the issue
none
anaconda log of the same install none

Description FRLinux 2007-03-31 10:01:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070321 Firefox/2.0.0.3

Description of problem:
Short before it is going to format a new partition to install FC, anaconda dies reporting an invalid agument and also give this : "This means Linux won't know about any changes you made to /dev/sda16 until you reboot -- so you shouldn't mount it or use it in any way before rebooting."

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. launch installer
2. select a free and unformated partition to install
3. make sure you have other partitions on your system which are unformated

Actual Results:
crashes anaconda, generates an exception

Expected Results:
format new partition, disregard other partitions on the drive, installs.

Additional info:
In this, partitions up to sda10 are formatted, all the rest is allocated but not formated yet.

fdisk  -l /dev/sda

Disk /dev/sda: 400.0 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1912    15358108+   c  W95 FAT32 (LBA)
/dev/sda2            1913        8924    56323890    7  HPFS/NTFS
/dev/sda3            8925       10749    14659312+  83  Linux
/dev/sda4           10750       48641   304367490    5  Extended
/dev/sda5           10750       28986   146488671   83  Linux
/dev/sda6           28987       29230     1959898+  82  Linux swap / Solaris
/dev/sda7           29231       31055    14659281   83  Linux
/dev/sda8           31056       32880    14659281   83  Linux
/dev/sda9           32881       34705    14659281   83  Linux
/dev/sda10          34706       36530    14659281   83  Linux
/dev/sda11          36531       38355    14659281   83  Linux
/dev/sda12          38356       40180    14659281   83  Linux
/dev/sda13          40181       42005    14659281   83  Linux
/dev/sda14          42006       43830    14659281   83  Linux
/dev/sda15          43831       45655    14659281   83  Linux
/dev/sda16          45656       48641    23985013+  83  Linux

Comment 1 FRLinux 2007-03-31 10:02:24 UTC
Created attachment 151345 [details]
anaconda dump of the issue

Comment 2 FRLinux 2007-03-31 10:03:24 UTC
Created attachment 151346 [details]
anaconda log of the same install

Comment 3 Jeremy Katz 2007-04-02 17:09:51 UTC
This is because there are more than 15 partitions on the disk and with using
libata, we can only have 15 partitions per disk. 

Comment 4 Matthew Miller 2007-04-10 16:36:11 UTC
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.

Comment 5 FRLinux 2007-04-10 19:55:45 UTC
I should have specified that I have seen this bug for a couple of releases now
(at least FC5 if i recall right) so I'd like to see it assigned if possible :)

Cheers.

Comment 6 David Cantrell 2007-04-19 22:01:48 UTC
Fixed in rawhide.  Right now this is a kernel limitation with the SCSI
subsystem.  All we can do in anaconda is detect that you have more than 15
partitions and present a warning dialog explaining the situation.