Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234509

Summary: TechnoTrend C1500 DVB card doesn't get a lock for one multiplex in Welho cable TV network when using kernel 2.6.20
Product: [Fedora] Fedora Reporter: Timo-Pekka Viljamaa <t-p>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: jarod, mkrufky
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.20-1.2952.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-31 18:50:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Timo-Pekka Viljamaa 2007-03-29 18:49:28 UTC
Description of problem: TechnoTrend C1500 DVB card doesn't get a lock for one
multiplex (138Mhz, QAM128, 6.9msym/s) in Finnish Welho cable TV network with
kernel 2.6.20 versions, worked ok with kernel 2.6.19-1.2911.6.5.fc6 and below.
All others multiplexes work ok with 2.6.20-1.2933.fc6.

Version-Release number of selected component (if applicable): 2.6.20-1.2933.fc6

How reproducible:
Using czap you can try to get lock for a channel from the multiplex.

Steps to Reproduce:
1. czap -a 0 -c channels.conf "Discovery" (channels.conf created using scandvb
from dvb-apps)
  
Actual results:
[mythtv@localhost .xine]$ czap -a 0 -c channels.conf "Discovery"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
112 Discovery:138000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_128:900:901:406
112 Discovery: f 138000000, s 6900000, i 2, fec 0, qam 4, v 0x384, a 0x385
status 00 | signal 0352 | snr 0601 | ber 00000000 | unc 00000000 |
status 00 | signal 0352 | snr 0692 | ber 00000000 | unc 00000000 |
status 00 | signal 0351 | snr 06a0 | ber 00000000 | unc 00000000 |
status 00 | signal 0351 | snr 075e | ber 00000000 | unc 00000000 |

Expected results:
With 2.6.19-1.2911.6.5.fc6:
[mythtv@localhost .xine]$ czap -a 0 -c channels.conf "Discovery"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
112 Discovery:138000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_128:900:901:406
112 Discovery: f 138000000, s 6900000, i 2, fec 0, qam 4, v 0x384, a 0x385
status 1f | signal 0339 | snr 0ea6 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 0339 | snr 12fa | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 0339 | snr 0fcb | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 033a | snr 1039 | ber 00000000 | unc 00000000 | FE_HAS_LOCK

Additional info:

Comment 1 Jarod Wilson 2007-03-29 19:23:29 UTC
Please give the 2937 test kernels at http://people.redhat.com/cebbert/kernels/ a
try. I suspect this may be fixed by one of the dvb patches added to that kernel.

Comment 2 Michael Krufky 2007-03-29 21:22:23 UTC
The only recent changeset that I see that might be relevant is:

http://linuxtv.org/hg/v4l-dvb?cmd=changeset;node=0a28cb2b61e4

...the card seems to be supported by saa7146 + stv0297

Try to revert the changeset above, and see if it fixes the problem.

Comment 3 Timo-Pekka Viljamaa 2007-03-29 21:32:04 UTC
(In reply to comment #1)
> Please give the 2937 test kernels at http://people.redhat.com/cebbert/kernels/ a
> try. I suspect this may be fixed by one of the dvb patches added to that kernel.

The 2937 test kernel didn't fix the problem.

Comment 4 Timo-Pekka Viljamaa 2007-03-29 21:44:39 UTC
(In reply to comment #2)
> The only recent changeset that I see that might be relevant is:
> 
> http://linuxtv.org/hg/v4l-dvb?cmd=changeset;node=0a28cb2b61e4
> 
> ...the card seems to be supported by saa7146 + stv0297
> 
> Try to revert the changeset above, and see if it fixes the problem.

I downloaded the latest V4L-DVB sources, reverted the stv0297.c and compiled it.
Didn't fix the problem.

Comment 5 Timo-Pekka Viljamaa 2007-04-28 06:00:00 UTC
Hi, there's a patch (not from me) in this Finnish linuxtv forum post that solves
the problem (currently last message):
http://www.linuxtv.fi/viewtopic.php?t=2169

This bug fix created the problem:
http://linuxtv.org/hg/v4l-dvb?cmd=changeset;node=e7c424bbf9aa;style=gitweb


Comment 6 Chuck Ebbert 2007-05-01 20:14:46 UTC
Apparently the proper fix is still unknown. The original code works
for some cards while the current code works for others.


Comment 7 Timo-Pekka Viljamaa 2007-05-04 06:04:38 UTC
There's now a fix committed to the code:
http://linuxtv.org/hg/v4l-dvb?cmd=changeset;node=23004ffaf979;style=gitweb

In linux-dvb mailing list there has been discussion and it seems that the fix
for Technotrend C1200 USB card was done to the wrong file, which then broke the
tuning with Technotrend C1500 card:
http://www.linuxtv.org/pipermail/linux-dvb/2007-May/017654.html

Comment 8 Chuck Ebbert 2007-05-16 21:30:09 UTC
Patch in next kernel.

Comment 9 Timo-Pekka Viljamaa 2007-05-31 17:41:23 UTC
Thanks, works ok in FC6. Is the same patch applied also to FC7's kernel?

Comment 10 Chuck Ebbert 2007-05-31 18:50:48 UTC
Patch submitted for FC-7 and upstream -stable release.