Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234416

Summary: libdir error on 64 bit
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: nagios-pluginsAssignee: Mike McGrath <mmcgrath>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jose.p.oliveira.oss, tjarls
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.4.8-4.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-13 17:08:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dennis Gilmore 2007-03-28 23:42:15 UTC
Description of problem:
/usr/lib64/nagios/plugins/check_linux_raid.pl  

has
use lib '/usr/lib/nagios/plugins';
where it should have 
use lib '/usr/lib64/nagios/plugins';

so it doesnt run correctly on 64 bit platforms

Version-Release number of selected component (if applicable):
nagios-plugins-linux_raid-1.4.5-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Charles Lopes 2007-08-10 07:50:32 UTC
This is caused by the fix for bug #212555. I would suggest removing patch 4 and
processing that perl script file the same way than the rest of the perl plugins.
Adding this line to the %build section:
gawk -f plugins-scripts/subst contrib/check_linux_raid.pl > contrib/check_linux_raid
And finally installing "check_linux_raid" instead of "check_linux_raid.pl",
again to be consistent with the rest of the perl plugins. That is, if a plugin
name change acceptable as it would break some configuration files.


Comment 2 Fedora Update System 2007-08-13 17:08:35 UTC
nagios-plugins-1.4.8-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.