Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234321

Summary: Uncompilable due to missing XLbx.h and lbxstr.h
Product: Red Hat Enterprise Linux 5 Reporter: Zenon Panoussis <redhatbugs>
Component: libXextAssignee: Søren Sandmann Pedersen <sandmann>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: kem, redhatbugs
Target Milestone: ---Flags: pm-rhel: needinfo? (redhatbugs)
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-02 13:16:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Zenon Panoussis 2007-03-28 13:58:05 UTC
Description of problem:
Compiling from src.rpm produces
XLbx.c: 34:33: error: X11/extensions/XLbx.h: No such file or directory
XLbx.c: 35:35: error: X11/extensions/lbxstr.h: No such file or directory

This causes some identifiers to be undeclared which in turn leads to errors and
breaks the compilation. 

I tried to find the missing files. Until FC5 they were part of
xorg-x11-proto-devel, on FC6 they're no longer there. rpm -qpl on the entire
5Server-beta2 binary distribution says they aren't there. Nor are they part of
the libXext source. 

Version-Release number of selected component (if applicable):
1.0.1-2.1

Comment 1 RHEL Product and Program Management 2014-03-07 13:42:07 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-02 13:16:38 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).