Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234263

Summary: anaconda hangs forever trying to get a dhcp address
Product: [Fedora] Fedora Reporter: Will Woods <wwoods>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-28 14:54:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    

Description Will Woods 2007-03-27 23:47:27 UTC
In anaconda-11.2.0.40-2, when the "Add additional software repositories button"
is clicked, anaconda always tries to fetch a dhcp address, whether the network
interface is configured or not. (see bug #232512).

Even if the device is not configured, the installer then hangs forever while
waiting for a dhcp response.

There should probably be a timeout on waiting for that response.

Comment 1 David Cantrell 2007-03-28 14:54:14 UTC

*** This bug has been marked as a duplicate of 232512 ***