Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234168

Summary: GFS2's rgrp flags unused
Product: [Fedora] Fedora Reporter: Steve Whitehouse <swhiteho>
Component: GFS-kernelAssignee: Steve Whitehouse <swhiteho>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bmarzins
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.20-1.2944 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-11 20:16:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235931    
Attachments:
Description Flags
Patch to fix this bug none

Description Steve Whitehouse 2007-03-27 15:33:32 UTC
GFS2 has a set of rgrp flags defined as part of its on disk format. The most
important of these is: GFS2_RGF_NOALLOC. Currently the gfs2 rgrp code ignores
all of these flags.

We will eventually need to add an interface which allows setting of the flags,
but for now, just making sure that the NOALLOC flag is obeyed correctly is the
priority so that its there for future use.

Ben, CCing you on this one since you've just been working on a bug in a smilar
area of the code.

Comment 1 Steve Whitehouse 2007-04-02 09:43:39 UTC
Created attachment 151411 [details]
Patch to fix this bug

This fixes the bug. Although it doesn't deal with all the flags, I can't
currently see any reasonable use for the data/metadata flag (in fact, due to
the allocation policy of GFS2, its actually a non-inode/inode flag despite its
name). So the only one which is really important here is the "noalloc" flag.