Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234113

Summary: [RHEL5] system datetime is getting slower and slower
Product: Red Hat Enterprise Linux 5 Reporter: Qingzhu Liu <qingzhuliu>
Component: kernel-xenAssignee: Brian Maly <bmaly>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Martin Jenner <mjenner>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: jburke, peterm, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-11 18:30:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 492570    

Description Qingzhu Liu 2007-03-27 03:52:26 UTC
Description of problem:

After synchronizing datetime with hw clock, the system time is getting slower
and slower. The system date is getting about twice slower. For example, now
hwclock time is: 20:00:00PM, after 5:00 min, the hw clock time is 20:05:00PM,
but the system time (date) is around 20:02:30PM. After 10 min, the hw clock time
is 20:10:00PM, but the system time (date) is around 20:05:00PM.

Version-Release number of selected component (if applicable):

How reproducible:
I tried in both gnome (the time shown in the upper right corner), and kde, and
got the same result.
I also tried from terminal using date command.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Comment 1 Tim Waugh 2007-03-27 08:16:52 UTC
Fixing component and reassigning.

Comment 2 Brian Maly 2007-08-28 15:38:17 UTC
Can you attach /var/log/dmesg? Also a lspci output?

I want to see what timesource is being used, and what the chipset is.

Comment 3 Qingzhu Liu 2007-08-28 17:30:12 UTC
It happens when I use xen kernel. But it is ok with regular kernel on the same


(In reply to comment #2)
> Can you attach /var/log/dmesg? Also a lspci output?
> I want to see what timesource is being used, and what the chipset is.

Comment 4 Jeff Burke 2007-09-25 18:19:13 UTC
Can you please provide a little more data.
1.) What is the hardware you are using. Vendor, Model, Bios version
2.) Can you please run the following commands and post the output.
  a.) lspci
  b.) cat /sys/devices/system/clocksource/clocksource0/available_clocksource
  c.) cat /sys/devices/system/clocksource/clocksource0/current_clocksource

Comment 5 RHEL Product and Program Management 2008-06-09 22:01:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update

Comment 6 Brian Maly 2008-08-07 02:32:09 UTC
Please provide info on clocksource being used, or attach /var/log/dmesg or sysreport (even better). Also provide some info on the type of system (mainboard vendor/model and processor vendor/model). There are many different causes of timeskew such as this. The requested information is essential to diagnosing and fixing this problem.

Comment 7 Brian Maly 2009-03-11 18:13:36 UTC
This BZ has been in a NEEDINFO state for a while now. Many timekeeping fixes have been applied to the Xen kernel since this bug was last active. Can we confirm this problem still exists and close this bug if there is no longer an issue?

Comment 9 Bill Burns 2009-03-11 18:30:32 UTC
Closing due to lack of response to need info request. Please reopen if you can supply the data required to work this issue.