Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 234101

Summary: Description refers to non-existant product
Product: [Fedora] Fedora Reporter: Stephen John Smoogen <smooge>
Component: setuptoolAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.19.3-1.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-07 18:06:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stephen John Smoogen 2007-03-27 00:54:06 UTC
Description of problem:

Name        : setuptool                    Relocations: (not relocatable)
Version     : 1.19.2                            Vendor: Red Hat, Inc.
Release     : 2                             Build Date: Fri 01 Dec 2006 10:47:31
AM MST
Install Date: (not installed)               Build Host: ls20-bc1-14.build.redhat.com
Group       : Applications/System           Source RPM: setuptool-1.19.2-2.src.rpm
Size        : 126541                           License: GPL
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : A text mode system configuration tool.
Description :
Setuptool is a user-friendly text mode menu utility which allows you
to access all of the text mode configuration programs included in the
Red Hat Linux operating system.

You should install the setuptool package because you will find
yourself using its features for essential system administration.

-----------------------------------

Does Red Hat Linux still exist in a Fedora context? Should Red Hat have (TM)
after it to help protect Red Hat's trademark? Should the sentance be changed to
something more generic?

Comment 1 Nalin Dahyabhai 2007-03-27 19:52:53 UTC
You know, I don't know about the trademark angle.  So I'm inclined to just
remove use of the distribution's name completely.

Comment 2 Stephen John Smoogen 2007-03-27 20:01:42 UTC
I was going through the various packages that mention Red hat Linux in them last
night and most had been changed in October of last year as changed.. but the
descriptions seemed to have changed back. The problem may be that the change has
to occur in the specspo package also?

Comment 3 Nalin Dahyabhai 2007-03-27 20:09:29 UTC
You should be able to compare the translated-by-specspo and untranslated
versions of the strings by setting LANG=C for the duration of one of your "rpm
-qi" calls:
  rpm -qi foo
  env LANG=C rpm -qi foo
If they differ, then the second one will be what's in the .spec file, and the
first will be what specso "translates" it to (even for en_US).

Comment 4 petrosyan 2008-01-07 17:28:23 UTC
This bug has been fixed:
$ rpm -qi setuptool
Name        : setuptool                    Relocations: (not relocatable)
Version     : 1.19.3                            Vendor: Fedora Project
Release     : 1.fc8                         Build Date: Thu 16 Aug 2007 02:34:23
PM EDT
Install Date: Fri 02 Nov 2007 11:46:02 AM EDT      Build Host:
xenbuilder4.fedora.phx.redhat.com
Group       : Applications/System           Source RPM:
setuptool-1.19.3-1.fc8.src.rpm
Size        : 133811                           License: GPLv2+
Signature   : DSA/SHA1, Thu 25 Oct 2007 08:27:47 AM EDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
Summary     : A text mode system configuration tool
Description :
Setuptool is a user-friendly text mode menu utility which allows you
to access all of the text mode configuration programs included in the
operating system distribution.

You should install the setuptool package because you may find
yourself using its features for essential system administration.


Comment 5 Nalin Dahyabhai 2008-01-07 18:06:52 UTC
Huh.  I missed that that had happened in time for F8.  Closing.  Thanks!