Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 233829

Summary: [PATCH] Make usermode building without gtk2 and libglade2
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: usermodeAssignee: Miloslav Trmač <mitr>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-26 10:08:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
usermode-1.91-fix_no_gtk2.patch none

Description Robert Scheck 2007-03-25 10:59:56 UTC
Description of problem:
I would like to see usermode building easily without having gtk2 and libglade2 
installed. As Red Hat seems to be upstream for usermode, I'm attaching my patch 
to this bug report here. And please don't remove the already existing defines 
in the C code which make X support conditional.

Version-Release number of selected component (if applicable):
usermode-1.91-1

Expected results:
Usermode building without gtk2 and libglade2.

Additional info:
My patch isn't complete regarding, configure.in and Makefile.am, which should 
be patched, too for getting stuff really conditional. But the attached patch 
solves my needs and should not make anybody worry.

Comment 1 Robert Scheck 2007-03-25 11:02:53 UTC
Created attachment 150847 [details]
usermode-1.91-fix_no_gtk2.patch

Comment 2 Miloslav Trmač 2007-03-26 10:08:11 UTC
Thanks, applied in CVS.