Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 233644

Summary: does not allow creation of qemu/kvm guests
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: virt-managerAssignee: Daniel Berrange <berrange>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: abartlet, dennis, mike.reeves, mishu, peter, redhat-bugzilla, uwe, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-18 23:53:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150226    
Attachments:
Description Flags
quick fix none

Description Jeremy Katz 2007-03-23 15:43:39 UTC
qemu/kvm guests aren't allowed to be created in virt-manager since it's checking
if the box is HVM capable.  But that check is Xen-centric.

Comment 1 Mike Reeves 2007-03-24 13:33:53 UTC
Running core 7 test 2 "Linux swamp-vmm 2.6.20-1.3017.fc7 #1 SMP Thu Mar 22
23:00:37 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux" I cannot build qemu or kvm
machines. I bring up the virtualization manager and KVM is not even in the list
so I select "qemu". I put in the server name and move to the next panel which
asks about the machine architecture. I select x686 or x86_64 and it puts up the
following message: "Hardware Support Required" with a description of "Your
hardware does not appear to support full virtualization.Only paravirtualized
guests will be available on this hardware."

I am running a Pentium D 930 which does support Intel VT. If I boot the Xen
kernel I can successfully create a fully virtualized guest (Fedora Core 6).


Comment 2 Mike Reeves 2007-03-27 22:03:32 UTC
(In reply to comment #0)
> qemu/kvm guests aren't allowed to be created in virt-manager since it's 
checking
> if the box is HVM capable.  But that check is Xen-centric.

I am not sure that I understand your response. Are you saying that a pentium D 
930 is not Intel VT? That is certainly not correct. Is it not supposed to be 
doing that check for KVM?

Or are you saying that the HVM check is "Xen" centric. I can create a fully 
virtualized guest in Xen.

Comment 3 Peter Gordon 2007-03-27 22:22:38 UTC
I just tried this on my Development install (updated as of last weekend) and it
works fine (allows the "Hardware acceleration" box to be checked/unchecked) if
you have the kvm and kvm-intel (or kvm-amd as appropriate) kernel modules loaded
and are installing to a supported guest (for example, KVM-acceleration of a x86
box on an x86_64 install would work, but virtualizing a PPC architecture would
have to be done in software).

Comment 4 Jeremy Katz 2007-03-28 18:49:22 UTC
Created attachment 151146 [details]
quick fix

A better fix would be to use the libvirt capabilities stuff, but this is a
quick fix to get things working again

Comment 5 Mike Reeves 2007-03-29 02:45:11 UTC
Jeremy - thx that got me past the issue. Kind of tired so i will try to put up 
the guest tomorrow. Peter - thx for the input. I am running the latest 1.3023 
kernel in x86_64 mode (updated day before yesterday) and from the virt mgr I 
selected x86_64 and x686 both yielding the same results. My processor is Intel 
VT capable (Pentium D 930). 

Comment 6 Mike Reeves 2007-03-29 18:53:22 UTC
This made it through the creation of the disk for the guest but finish the 
install I received the following error  in a dialog box:

Guest Install Error
ERROR: virDomainCreateLinux() failed internal error No <source> 'dev' 
attribute specified with <interface type='bridge'/>



Comment 7 Mike Reeves 2007-04-10 01:39:26 UTC
Unfortunately this fix only corrected the initial problem and now the source
that I have downloaded is backlevel and the new source does not appear to be
downloadable yet. Consequently I tried to use the native qemu from the command
line and I get the following notation when I start an install:
"[root@swamp-vmm vm]# qemu -hda /vm/swampsol1.img -cdrom /dev/cdrom -boot d
-kernel-kqemu -m 768
Could not open '/dev/kqemu' - QEMU acceleration layer not activated"
The install for solaris does not work well and I cannot get fc7 to work at all
from the command line. I will be unavailable from the 11th through the 24th but
I would be happy to test whatever is available upon my return.


Comment 8 Andrew Bartlett 2007-04-10 07:28:33 UTC
This appears to be the same as what this patch went in to fix:
http://www.redhat.com/archives/fedora-cvs-commits/2007-February/msg01305.html

However the patch has been backed out, I presume while upgrading to the latest
release. 

Comment 9 Uwe Kubosch 2007-04-13 13:31:55 UTC
I am having the same problem as described in comment #6  Is there a solution for
this?

Comment 10 Jeremy Katz 2007-04-18 23:53:44 UTC
Works now