Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 233566

Summary: [RHEL-3] Turkey DST Update
Product: Red Hat Enterprise Linux 3 Reporter: Petr Machata <pmachata>
Component: tzdataAssignee: Petr Machata <pmachata>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.8CC: mnewsome
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHEA-2007-0128 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-23 22:15:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 233565    
Bug Blocks: 233567    

Description Petr Machata 2007-03-23 09:31:59 UTC
+++ This bug was initially created as a clone of Bug #233565 +++

Description of problem:

   DST switch times are changed to 1am UTC in Turkey starting with 2007 for EU 
conformity. But with RHEL 4 Update 4:

  # zdump -v Turkey | grep 2007
  Turkey  Sat Mar 24 22:59:59 2007 UTC = Sun Mar 25 00:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sat Mar 24 23:00:00 2007 UTC = Sun Mar 25 02:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 22:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 23:00:00 2007 UTC = Sun Oct 28 01:00:00 2007 EET isdst=0
gmtoff=7200

Version-Release number of selected component (if applicable):
   tzdata-2007c-1.el4

How reproducible: 
   Consistently

Steps to Reproduce:
1.    zdump -v Turkey | grep 2007

Actual results:
  Turkey  Sat Mar 24 22:59:59 2007 UTC = Sun Mar 25 00:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sat Mar 24 23:00:00 2007 UTC = Sun Mar 25 02:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 22:59:59 2007 UTC = Sun Oct 28 01:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sat Oct 27 23:00:00 2007 UTC = Sun Oct 28 01:00:00 2007 EET isdst=0
gmtoff=7200


Expected results:
  Turkey  Sun Mar 25 00:59:59 2007 UTC = Sun Mar 25 02:59:59 2007 EET isdst=0
gmtoff=7200
  Turkey  Sun Mar 25 01:00:00 2007 UTC = Sun Mar 25 04:00:00 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sun Oct 28 00:59:59 2007 UTC = Sun Oct 28 03:59:59 2007 EEST isdst=1
gmtoff=10800
  Turkey  Sun Oct 28 01:00:00 2007 UTC = Sun Oct 28 03:00:00 2007 EET isdst=0
gmtoff=7200

Additional info:

   With tzdata-2006m-2.fc6 on RHEL5, the problem does not exist.

-- Additional comment from pmachata@redhat.com on 2007-03-23 05:29 EST --
Right, 2007d contains the necessary updates.  2006m is only correct because
there was a bug in assuming that Turkey used and will use EU rules, which they
are only using this year.

In any case, we'll need to get this out ASYNC for all RHELs.

Comment 6 Red Hat Bugzilla 2007-03-23 22:15:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0128.html