Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 233374

Summary: iwlwifi oops with kernel-2.6.20-1.2999.fc7
Product: [Fedora] Fedora Reporter: Richard Hughes <richard>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: cebbert, davej
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-14 21:25:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
oops output due to null dereference none

Description Richard Hughes 2007-03-21 21:37:19 UTC
Description of problem:

iwlwifi oops on kernel-2.6.20-1.2999.fc7

Yell if you need any more info. Thanks guys.

Oops here:

Mar 21 21:02:53 localhost kernel: PCI: Enabling device 0000:05:06.0 (0000 -> 0002)
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:05:06.0[A] -> GSI 22
(level, low) -> IRQ 21
Mar 21 21:02:53 localhost kernel: intel_rng: FWH not detected
Mar 21 21:02:53 localhost kernel: fw_ohci: Added fw-ohci device 0000:05:06.0,
OHCI version 1.10
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 19
(level, low) -> IRQ 19
Mar 21 21:02:53 localhost kernel: sdhci: Secure Digital Host Controller
Interface driver
Mar 21 21:02:53 localhost kernel: sdhci: Copyright(c) Pierre Ossman
Mar 21 21:02:53 localhost kernel: Bluetooth: HCI USB driver ver 2.9
Mar 21 21:02:53 localhost kernel: usbcore: registered new interface driver hci_usb
Mar 21 21:02:53 localhost kernel: input: PC Speaker as /class/input/input3
Mar 21 21:02:53 localhost kernel: sdhci: SDHCI controller found at 0000:05:06.1
[1180:0822] (rev 19)
Mar 21 21:02:53 localhost kernel: PCI: Enabling device 0000:05:06.1 (0000 -> 0002)
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:05:06.1[B] -> GSI 23
(level, low) -> IRQ 18
Mar 21 21:02:53 localhost kernel: mmc0: SDHCI at 0xd2100400 irq 18 DMA
Mar 21 21:02:53 localhost kernel: iwlwifi: Intel(R) Wireless Link driver for
Linux, 0.0.11k
Mar 21 21:02:53 localhost kernel: iwlwifi: Copyright(c) 2003-2006 Intel Corporation
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17
(level, low) -> IRQ 17
Mar 21 21:02:53 localhost kernel: iwlwifi: Detected Intel PRO/Wireless 3945ABG
Network Connection
Mar 21 21:02:53 localhost kernel: 8139too Fast Ethernet driver 0.9.28
Mar 21 21:02:53 localhost kernel: fw_core: created new fw device fw0 (0 config
rom retries)
Mar 21 21:02:53 localhost kernel: usb 5-5: reset high speed USB device using
ehci_hcd and address 4
Mar 21 21:02:53 localhost kernel: rtc_cmos 00:08: rtc core: registered rtc_cmos
as rtc0
Mar 21 21:02:53 localhost kernel: rtc_cmos: probe of 00:08 failed with error -16
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:05:01.0[A] -> GSI 21
(level, low) -> IRQ 22
Mar 21 21:02:53 localhost kernel: eth0: RealTek RTL8139 at 0xf8a00000,
00:0f:b0:c7:fd:8f, IRQ 22
Mar 21 21:02:53 localhost kernel: zd1211rw_mac80211 5-5:1.0: firmware version 4725
Mar 21 21:02:53 localhost kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22
(level, low) -> IRQ 21
Mar 21 21:02:53 localhost kernel: zd1211rw_mac80211 5-5:1.0: zd1211b chip
0ace:1215 v4810 high 00-16-e0 AL2230_RF pa0 ---N
Mar 21 21:02:53 localhost kernel: 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar
22, 2004)
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 14 [2.4Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 183 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 184 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 185 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 187 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 188 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 189 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 192 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 196 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 7 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 8 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 11 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 12 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 16 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 145 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 149 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 153 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 157 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 161 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Channel 165 [5.2Ghz] is Tx only --
skipping.
Mar 21 21:02:53 localhost kernel: iwlwifi: Tunable channels: 13 802.11bg, 23
802.11a channels
Mar 21 21:02:53 localhost kernel: iwlwifi: XXXY start rate scale
Mar 21 21:02:53 localhost kernel: iwlwifi: XXXY start rate scale
Mar 21 21:02:53 localhost kernel: BUG: unable to handle kernel paging request at
virtual address 6b6b6ceb
Mar 21 21:02:53 localhost kernel:  printing eip:
Mar 21 21:02:53 localhost kernel: c0448037
Mar 21 21:02:53 localhost kernel: *pde = 00000000
Mar 21 21:02:53 localhost kernel: Oops: 0002 [#1]
Mar 21 21:02:53 localhost kernel: SMP 
Mar 21 21:02:53 localhost kernel: last sysfs file: /class/net/lo/type
Mar 21 21:02:53 localhost kernel: Modules linked in: arc4 ecb blkcipher
rc80211_simple 8139cp snd_hda_intel snd_hda_codec rtc_cmos snd_seq_dummy
snd_seq_oss snd_seq_midi_event rtc_core snd_seq rtc_lib zd1211rw_mac80211
snd_seq_device 8139too snd_pcm_oss iwlwifi serio_raw mii pcspkr hci_usb sdhci
snd_mixer_oss mac80211 i2c_i801 mmc_core fw_ohci iTCO_wdt fw_core
iTCO_vendor_support cfg80211 snd_pcm bluetooth i2c_core snd_timer snd soundcore
snd_page_alloc sr_mod cdrom sg joydev ata_piix ata_generic libata sd_mod
scsi_mod ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
Mar 21 21:02:53 localhost kernel: CPU:    0
Mar 21 21:02:53 localhost kernel: EIP:    0060:[<c0448037>]    Not tainted VLI
Mar 21 21:02:53 localhost kernel: EFLAGS: 00210246   (2.6.20-1.2999.fc7 #1)
Mar 21 21:02:53 localhost kernel: EIP is at module_put+0x19/0x2d
Mar 21 21:02:53 localhost kernel: eax: 6b6b6ceb   ebx: f7722554   ecx: c047981d
  edx: 6b6b6b6b
Mar 21 21:02:53 localhost kernel: esi: f7722554   edi: 0000008f   ebp: f7784bb0
  esp: f7784bb0
Mar 21 21:02:53 localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Mar 21 21:02:53 localhost kernel: Process modprobe (pid: 1147, ti=f7784000
task=f76d4030 task.ti=f7784000)
Mar 21 21:02:53 localhost kernel: Stack: f7784bbc c04d9844 f71c2c9c f7784bcc
c04d98e7 f7722554 00000000 f7784bec 
Mar 21 21:02:53 localhost kernel:        c04d9a93 f8a29277 f8a29277 00000004
f72702e0 00000000 0000008f f7784c08 
Mar 21 21:02:53 localhost kernel:        c04d9cc8 00000004 f8a29277 f72702e0
00000000 20104810 f7784c14 f8a1cc14 
Mar 21 21:02:53 localhost kernel: Call Trace:
Mar 21 21:02:53 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 21 21:02:53 localhost kernel:  [<c040629d>] show_stack_log_lvl+0x9b/0xa3
Mar 21 21:02:53 localhost kernel:  [<c040645d>] show_registers+0x1b8/0x289
Mar 21 21:02:53 localhost kernel:  [<c040665b>] die+0x12d/0x242
Mar 21 21:02:53 localhost kernel:  [<c061727e>] do_page_fault+0x3ee/0x4ba
Mar 21 21:02:53 localhost kernel:  [<c0615a14>] error_code+0x7c/0x84
Mar 21 21:02:53 localhost kernel:  [<c04d9844>] crypto_mod_put+0x2a/0x2d
Mar 21 21:02:53 localhost kernel:  [<c04d98e7>] crypto_larval_wait+0x40/0x46
Mar 21 21:02:53 localhost kernel:  [<c04d9a93>] crypto_alg_mod_lookup+0x5f/0x1c9
Mar 21 21:02:53 localhost kernel:  [<c04d9cc8>] crypto_alloc_base+0x1e/0x66
Mar 21 21:02:53 localhost kernel:  [<f8a1cc14>] ieee80211_wep_init+0x2a/0x76
[mac80211]
Mar 21 21:02:53 localhost kernel:  [<f8a14fb5>]
ieee80211_register_hw+0x128/0x1c3 [mac80211]
Mar 21 21:02:53 localhost kernel:  [<f8a58d7d>] probe+0x440/0x52e
[zd1211rw_mac80211]
Mar 21 21:02:53 localhost kernel:  [<c0579e93>] usb_probe_interface+0x60/0x83
Mar 21 21:02:53 localhost kernel:  [<c05621f9>] really_probe+0xc7/0x150
Mar 21 21:02:53 localhost kernel:  [<c0562317>] driver_probe_device+0x95/0xa1
Mar 21 21:02:53 localhost kernel:  [<c056243f>] __driver_attach+0x76/0xaf
Mar 21 21:02:53 localhost kernel:  [<c05617cd>] bus_for_each_dev+0x3a/0x5f
Mar 21 21:02:53 localhost kernel:  [<c0562063>] driver_attach+0x19/0x1b
Mar 21 21:02:53 localhost kernel:  [<c0561ab4>] bus_add_driver+0x6a/0x170
Mar 21 21:02:53 localhost kernel:  [<c0562665>] driver_register+0x79/0x7e
Mar 21 21:02:53 localhost kernel:  [<c05799de>] usb_register_driver+0x7e/0xe5
Mar 21 21:02:53 localhost kernel:  [<f89ef051>] usb_init+0x51/0x82
[zd1211rw_mac80211]
Mar 21 21:02:53 localhost kernel:  [<c0449761>] sys_init_module+0x159b/0x16ea
Mar 21 21:02:53 localhost kernel:  [<c040507c>] syscall_call+0x7/0xb
Mar 21 21:02:53 localhost kernel:  =======================
Mar 21 21:02:53 localhost kernel: Code: 0a 00 89 f8 e8 0f 73 0a 00 89 d8 5b 5e
5b 5e 5f 5d c3 55 85 c0 89 e5 89 c2 74 22 64 a1 04 00 00 00 c1 e0 07 8d 84 10 80
01 00 00 <ff> 08 83 3a 02 75 0b 8b 82 88 11 00 00 e8 ac a7 fd ff 5d c3 55 
Mar 21 21:02:53 localhost kernel: EIP: [<c0448037>] module_put+0x19/0x2d SS:ESP
0068:f7784bb0
Mar 21 21:02:53 localhost kernel: BUG: workqueue leaked lock or atomic:
iwlwifi/0/0x00000000/1224
Mar 21 21:02:53 localhost kernel:     last function:
ipw_bg_alive_start+0x0/0x11d3 [iwlwifi]
Mar 21 21:02:53 localhost kernel: 1 lock held by iwlwifi/0/1224:
Mar 21 21:02:53 localhost kernel:  #0:  (&priv->mutex){--..}, at: [<c061419a>]
mutex_lock+0x21/0x24
Mar 21 21:02:53 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 21 21:02:53 localhost kernel:  [<c04067b1>] show_trace+0x12/0x14
Mar 21 21:02:53 localhost kernel:  [<c0406835>] dump_stack+0x16/0x18
Mar 21 21:02:53 localhost kernel:  [<c04351c4>] run_workqueue+0xfe/0x145
Mar 21 21:02:53 localhost kernel:  [<c0435b6b>] worker_thread+0xf8/0x124
Mar 21 21:02:53 localhost kernel:  [<c0438357>] kthread+0xb3/0xdc
Mar 21 21:02:53 localhost kernel:  [<c0405cd7>] kernel_thread_helper+0x7/0x10
Mar 21 21:02:53 localhost kernel:  =======================
Mar 21 21:02:53 localhost kernel: si3054: cannot initialize. EXT MID = 0000

Comment 1 Richard Hughes 2007-03-23 17:39:35 UTC
Created attachment 150777 [details]
oops output due to null dereference

Got the attached NULL pointer dereference this morning just from booting. Hard
hang, numlock was just flashing. This is with 2.6.20-1.3016.fc7.

Comment 2 John W. Linville 2007-03-23 18:00:44 UTC
Ooops in comment 1 is same issue as bug 233364, fwiw...I don't think it 
relates to the original report in this bug.

Comment 3 John W. Linville 2007-04-20 18:06:30 UTC
Is this still happening with current rawhide kernels?  There have been several 
mac80211 and iwlwifi updates in the meantime...

Comment 4 Richard Hughes 2007-05-11 16:15:52 UTC
No segfault, although it now does do something odd with my interrupts, causing
my mouse to loose sinc every 20~ seconds and my keyboard to go odd on shutdown.
If I remove the module then everything is okay, so I'm pretty sure its iwl3945.

Comment 5 John W. Linville 2007-05-14 21:25:03 UTC
Others are seeing the keyboard issue as well, but I haven't seen a bug 
opened -- would you mind doing that?

I'm going to close this one since the keyboard problem is a separate issue.

Comment 6 Richard Hughes 2007-05-17 11:08:00 UTC
John, I've switched to a x60 for the foreseeable future, although I can still
test stuff on my n100 if you need me to. On the x60 the iwl3945 driver work
flawlessly, except with suspend/resume, but that's a seporate issue.