Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232991

Summary: sata_sil causes system freeze
Product: [Fedora] Fedora Reporter: Robert M Williams <rwilliam>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: triage, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-07 01:18:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
lspci information
dmesg output
messages log
install log
install syslog none

Description Robert M Williams 2007-03-19 19:46:30 UTC
Description of problem:
during the loading of the sata_sil driver the system will freeze until a mouse/
keyboard event occurs.
it will freeze again moments later until another mouse/keyboard event takes 
if no mouse/keyboard event occurs 'Clocksource tsc unstable (delta=14059955850 
ns)' occurs

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot system 'PM: Adding info for No Bus :host1' message system will freeze proceed continous mouse movement is reqired for entire session (including 
logoff) or freeze will occur
Actual results:
system freeze

Expected results:
'normal' operation without continous input

Additional info:
- AMD Turion X2 based CPU 1.6 GHz
- 1 GB DDR2 ram
- 80GB hd (sata based)
- dvd+-rw (ata based)

This does not occur if using the x86_64 version of Fedora 7 b2 on the same 

have tried changing the clock source via kernel params (pit and pmtmr) with no 

have tried adding libata.atapi_enabled=1 to no effect

have applied latest update as of time of bug filing

does not occur on 'PM: Adding info for No Bus :host0' load

Comment 1 Robert M Williams 2007-03-19 19:52:20 UTC
*** Bug 232992 has been marked as a duplicate of this bug. ***

Comment 2 Robert M Williams 2007-03-19 19:56:27 UTC
Created attachment 150425 [details]
lspci information

Comment 3 Robert M Williams 2007-03-19 19:57:44 UTC
Created attachment 150426 [details]
dmesg output

Comment 4 Robert M Williams 2007-03-19 20:01:38 UTC
Created attachment 150428 [details]
messages log

Comment 5 Robert M Williams 2007-03-19 20:03:42 UTC
Created attachment 150429 [details]
install log

Comment 6 Robert M Williams 2007-03-19 20:04:18 UTC
Created attachment 150430 [details]
install syslog

Comment 7 Chuck Ebbert 2007-03-26 14:48:14 UTC
Test kernels (version 1.2937) for this issue are at:

Please test and report back.

Comment 8 Robert M Williams 2007-03-26 18:35:26 UTC
tried build 20070325 (kernel 2.6.20-1.3017) and now the problem occurs before
sata_sil loads
it now begins with /sbin/loader notification
as before constant mouse or keyboard events allow the system to proceed

Comment 9 Chuck Ebbert 2007-03-26 18:48:51 UTC
Sorry, I thought this was an FC6 bug.

Comment 10 Robert M Williams 2007-03-26 19:09:27 UTC
plugged in an external usb mouse and install proceeds with fewer movements required.
however after the hard disk formats and 'transfering install image' is displayed
the screen goes white and system hard locks.

Comment 11 Dave Jones 2007-04-23 16:47:43 UTC
options to try booting with..

noapic nolapic

Comment 12 Bug Zapper 2008-04-03 23:43:38 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 13 Bug Zapper 2008-05-07 01:18:48 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here: