Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232764

Summary: wpa_supplicant warning
Product: [Fedora] Fedora Reporter: Ronny Fischer <ronny.fischer>
Component: wpa_supplicantAssignee: Dan Williams <dcbw>
Status: CLOSED WORKSFORME QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-26 14:26:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ronny Fischer 2007-03-17 11:29:27 UTC
Description of problem:
the wpa_supplicant daemon produces a warning of missing function when starting

Version-Release number of selected component (if applicable):
Fedora 7 (since Test 1), wpa_supplicant 0.4.9 and also 0.5.7

How reproducible:
always

Steps to Reproduce:
1.start wpa_supplicant on i686
2.
3.
  
Actual results:
a warning appears

Expected results:
no warnings expected

Additional info:
warning is as follows:

wpa_supplicant starten: ioctl[SIOCSIWPMKSA]: Function not implemented

I'm not sure about this ioctl but using wpa_supplicant on FC6 does not produce 
a warning like that.

It's not a fault but quiet a bit annoying

Comment 1 Dan Williams 2007-03-17 17:27:22 UTC
What type of card do you have?  This warning is wpa_supplicant saying the driver
doesn't support some sort of functionality which is pretty normal for many older
cards that don't do WPA or all the features of WPA.

Comment 2 Ronny Fischer 2007-03-18 09:27:58 UTC
The card is an Intel PRO Wireless 2200 B/G running with the ipw2200 driver 
provided by the kernel on a Thinkpad R52. The kernel is actually 2.6.20-1.2990, 
but the warning appeard with every kernel version since the first test release 
of Fedora 7. AFAIK the card itself provides WPA support together with 
wpa_supplicant. I'm don't believe that this has something to do with it.

Running a self-build version of wpa_supplicant 0.5.7 with FC6 on the same 
machine never produces a warning like this. I'm gonna rebuild my version for 
Fedora 7 Test 2 to see if this is the source of the problem. I will provide 
further information about it when this is finished.

Comment 3 Ronny Fischer 2007-03-18 10:20:07 UTC
The warning still remains even when I use my self-build version of 
wpa_supplciant. So I guess this isn't a fault by wpa_supplicant. I'm not sure 
but could it be a debug warning of some other used software (maybe from the 
driver itself) that generates this warning?

Thx for reply

Comment 4 Matthew Miller 2007-04-10 15:54:44 UTC
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.

Comment 5 Ronny Fischer 2007-05-31 20:25:34 UTC
A new installation of fedora 7 final does no longer display any warning 
messages form wpa_supplicant.

I would suggest to close the bug report.

Comment 6 Ronny Fischer 2007-07-26 14:26:14 UTC
The bug no longer exists for me since some time.