Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232711

Summary: RFE reads should trigger a down conversion of a failed cmirror
Product: [Retired] Red Hat Cluster Suite Reporter: Corey Marthaler <cmarthal>
Component: cmirrorAssignee: LVM and device-mapper development team <lvm-team>
Status: CLOSED WONTFIX QA Contact: Cluster QE <mspqa-list>
Severity: low Docs Contact:
Priority: low    
Version: 4CC: agk, dwysocha, jbrassow, mbroz, prockai
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-17 21:54:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 233031    

Description Corey Marthaler 2007-03-16 19:23:55 UTC
Description of problem:
If a user has an application reading off of a failed cmirror (or does a read
before a write in a non-synced cmirror), their mirror wont get auto down
converted, instead the applications will just fail due to I/O errors.

Comment 1 Corey Marthaler 2007-04-12 17:49:48 UTC
*** Bug 233031 has been marked as a duplicate of this bug. ***

Comment 2 Corey Marthaler 2007-04-12 18:19:09 UTC
*** Bug 226815 has been marked as a duplicate of this bug. ***

Comment 3 Corey Marthaler 2009-01-16 14:57:32 UTC
Did this issue get resolved in the past year? It seems that a read does now trigger a down conversion to a failed mirror.

Comment 5 Jonathan Earl Brassow 2010-05-17 21:54:31 UTC
A read still should not be triggering a down convert... but we might want it to issue a restorative write (causing block relocation on the drive).

I'm closing this bug WONTFIX, but a new bug (under a newer rhel version) to add a restorative write attempt after a read failure might be something to consider as a feature request.