Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232484

Summary: RHEL4 missing db4-*-devel-*ppc64-*
Product: Red Hat Enterprise Linux 4 Reporter: Michael Moon <michael.moon>
Component: distributionAssignee: Mike McLean <mikem>
Status: CLOSED CURRENTRELEASE QA Contact: Daniel Riek <riek>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.3CC: dmach, jlaska, jneedham, pm-rhel
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: 4.5.z Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-05-14 20:36:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 239993    

Description Michael Moon 2007-03-15 18:30:48 UTC
Description of problem:
Our RHEL4u3 on PPC64 box has the following installed:

db4-devel-4.2.52-7.1.ppc.rpm
db4-4.2.52-7.1.ppc.rpm
db4-4.2.52-7.1.ppc64.rpm
expat-devel-1.95.7-4.ppc.rpm
expat-1.95.7-4.ppc.rpm
expat-1.95.7-4.ppc64.rpm
gdbm-devel-1.8.0-24.ppc.rpm
gdbm-1.8.0-24.ppc.rpm
gdbm-1.8.0-24.ppc64.rpm

Note that the ppc64 versions of the *devel* packages are not there. This effect
of this is that we're missing the following libraries required for Application
Server:

/usr/lib64/libdb.so
/usr/lib64/libexpat.so
/usr/lib64/libgdbm.so

Bugzilla doesn't allow me to pick multiple components so I picked for just db4.
If I need to create other bugzilla reports, please let me know.

Thanks,
-Mike

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michael Moon 2007-03-15 18:32:50 UTC
When I say "Application Server" above, I meant the "Oracle" Application Server.

Comment 2 Jay Turner 2007-03-15 20:11:15 UTC
I'm actually changing this to be against "distribution" since that's where the
fix would actually be.  No need for separate BZs for each component.

Comment 7 Mike McLean 2007-05-07 19:45:53 UTC
Based on a quick look, these -devel packages seem to be multilib safe, and I
don't think they will pull anything else in.

Comment 8 Michael Moon 2007-05-07 19:59:12 UTC
(In reply to comment #7)
> Based on a quick look, these -devel packages seem to be multilib safe, and I
> don't think they will pull anything else in.

We need the following files available on our RHEL4 PPC64 box:
/usr/lib64/libdb.so
/usr/lib64/libexpat.so
/usr/lib64/libgdbm.so
Whatever versions of the rpms that include these, we don't care.

Comment 19 Mike McLean 2007-05-14 20:36:43 UTC
The requested packages are now available from RHN. You can install them with
this command:
$ up2date -i db4-devel expat-devel gdbm-devel  --arch ppc64



Comment 20 Michael Moon 2007-05-14 20:56:17 UTC
Will this be part of RHEL4 Update5 or Update6? Thanks.

Comment 21 Mike McLean 2007-05-14 21:06:02 UTC
Yes, this change will also be applied in 4.6.  That is being tracked in bug 239993.

Comment 22 Jay Turner 2007-08-29 12:53:30 UTC
$ pwd
/mnt/redhat/rel-eng/RHEL4-U6-re20070814.0/ppc/ppc-AS/RedHat/RPMS

$ ls db4-devel*.ppc64.rpm expat-devel*.ppc64.rpm gdbm-devel*.ppc64.rpm
db4-devel-4.2.52-7.3.el4.ppc64.rpm  expat-devel-1.95.7-4.ppc64.rpm 
gdbm-devel-1.8.0-24.ppc64.rpm