Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232428

Summary: vncviewer does not use the same font path as a console
Product: Red Hat Enterprise Linux 4 Reporter: Suzanne Hillman <shillman>
Component: vncAssignee: Adam Tkac <atkac>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.4CC: aalam, desktop-bugs, ovasik
Target Milestone: ---Keywords: Desktop
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-17 11:13:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Suzanne Hillman 2007-03-15 14:29:54 UTC
Description of problem:
vncviewer does not use the same font path as a console. vncviewer appears to set
a font path, rather than using the font server. This can cause interesting
inconsistencies between console-based testing involving fonts and VNC-based
testing. To fix this, set the font path (via "xset fp= unix/:7100" in your VNC
session) to use the font server.

Version-Release number of selected component (if applicable):
vnc-4.1.2-9.el5

How reproducible:
Always

Steps to Reproduce:
1. Connect to a machine via VNC.
2. Attempt to run the test case in bug #189849
  
Actual results:
Fails because of "Could not create fontset for -*-*-*-R-Normal--14-130-75-75-*-*"

Expected results:
Should just work.

Additional info:
I am unsure if the font server would always be unix/:7100. It might be better to
figure out a way to query what the machine would normally do, and use that.

Comment 1 Adam Tkac 2007-03-27 15:17:45 UTC
Are you really sure that this bug exists in rhel5? vnc works perfectly on rhel5
for me. I run vncserver, with default configuration and I've see nothing related
to this bug (no error like "Could not create fontset.. "). Update rhel version
or give me access for affected machine or upload server's logfile.

Regards, Adam

Comment 2 A S Alam 2007-04-12 12:49:43 UTC
I was also not able to reproduce this bug with mention file on RHEL5 machine


Comment 3 A S Alam 2007-04-12 13:21:03 UTC
tested with bug #189849 Comment #12's Attachment

Comment 4 Adam Tkac 2007-04-12 16:40:53 UTC
(In reply to comment #3)
I was confused because this bug has been opened against rhel5. Let me check
potential problems on rhel4 (also moving this bug to rhel4)

-A-



Comment 6 Adam Tkac 2007-04-17 11:13:38 UTC
I tried reproduce bug on up2date rhel4 system and I wasn't successfull. I also
tested with bug #189849 Comment #12's Attachment and all works fine (no "could
not create font path" message). If you're still able to reproduce this one,
please reopen.

-A-