Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232375

Summary: Listview Filter Box Issue on Users List
Product: Red Hat Network Reporter: Máirín Duffy <duffy>
Component: RHN/Web SiteAssignee: rhn-dev-list
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Network Quality Assurance <rhn-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: rhn500CC: ggainey, inode0, paji, rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: us=120853
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-29 12:10:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Máirín Duffy 2007-03-15 01:47:56 UTC
The filter box widget no longer seems to be filtering on the users page (ex.
https://rhn.redhat.com/rhn/users/ActiveList.do)

For example, say I have 3 accounts in my user list:

foobar1
foobar2
foobar3

I think previously, had I entered 'bar' in the filter box, it would have
returned all three of these. Now, if I enter 'bar' in the filter box, it does'nt
return any of these.

The filter should filter throughout the string, not just from the beginning.

There are other listviews (eg. software channels) where entering 'bar' would
return all three. (e.g., try filtering for 'fastrack' in a channel list. it'll
return them even though 'fastrack' isn't at the beginning of any channel names)

Comment 1 Máirín Duffy 2007-03-15 02:02:27 UTC
(note that on the users page, in my example, had i filtered by 'foo' foobar1 -
foobar3 would have turned up. but if i filtered bar 'bar', none of them would
have turned up. hope that makes the issue a little more clear.)

Comment 2 Bret McMillan 2007-03-16 20:04:28 UTC
punting to 505.

Comment 3 Partha Aji 2007-03-19 23:05:31 UTC
Added it to /trunk/hosted and /trunk/satellite.. Should be in the next 505 push...

Comment 4 Grant Gainey 2007-04-24 19:15:48 UTC
Partha - can you recheck this?  Your comment says it was fixed in March, but the
behavior Mo notes is still happening on 5.0.1.  If it works in satellite, could
you add the SVN revision that has the fix to this BZ please?



Comment 5 Grant Gainey 2009-07-23 19:38:23 UTC
Retested.  The behavior described as a bug has never been fixed.

Comment 6 Grant Gainey 2014-08-29 12:10:14 UTC
At some point in the last 5 years, this appears to have been fixed - closing.