Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 232237

Summary: Kickstart install on software RAID fails
Product: [Fedora] Fedora Reporter: Ralf Kleineisel <ralf>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-26 14:38:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Anaconda dump none

Description Ralf Kleineisel 2007-03-14 15:17:52 UTC
Description of problem:
Unable to kickstart install a PC with mirrored (md) disk.

Version-Release number of selected component (if applicable):
2.6.17-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Make a kickstart config file with system-config-kickstart
2. Boot a PC with kickstart option
3.
  
Actual results:
Error message:
ValueError: md0 is already in the mdList!

The partitions are made correctly (checked on the shell).


Expected results:


Additional info:
Here is the relevant part of the kickstart file:
# Disk partitioning information
part raid.01 --bytes-per-inode=4096 --fstype="raid" --ondisk=sda --size=128
part raid.03 --bytes-per-inode=4096 --fstype="raid" --ondisk=sda --size=10240
part swap --bytes-per-inode=4096 --fstype="swap" --ondisk=sda --size=1024
part raid.05 --bytes-per-inode=4096 --fstype="raid" --grow --ondisk=sda --size=1
part raid.02 --bytes-per-inode=4096 --fstype="raid" --ondisk=sdb --size=128
part raid.04 --bytes-per-inode=4096 --fstype="raid" --ondisk=sdb --size=10140
part swap --bytes-per-inode=4096 --fstype="swap" --ondisk=sdb --size=1024
part raid.06 --bytes-per-inode=4096 --fstype="raid" --grow --ondisk=sdb --size=1
raid /boot --bytes-per-inode=4096 --device=md0 --fstype="ext3" --level=1 raid.01
raid.02
raid / --bytes-per-inode=4096 --device=md1 --fstype="ext3" --level=1 raid.03 raid.04
raid /data --bytes-per-inode=4096 --device=md2 --fstype="ext3" --level=1 raid.05
raid.06

Comment 1 Ralf Kleineisel 2007-03-14 15:56:19 UTC
Created attachment 150060 [details]
Anaconda dump

I tried to add a "--noformat" option to all "part" instructions, but it didn't
help

Comment 2 Ralf Kleineisel 2007-03-14 16:48:23 UTC
I tried the following, more minimalistic config but got the same error:

part raid.01 --size=128 --ondisk=sda
part raid.02 --size=128 --ondisk=sdb
part raid.11 --size=10240 --ondisk=sda
part raid.12 --size=10240 --ondisk=sdb
part raid.21 --size=1 --grow --ondisk=sda
part raid.22 --size=1 --grow --ondisk=sdb
part swap --size=1024 --ondisk=sda
part swap --size=1024 --ondisk=sdb
raid /boot --level=1 --device=md0 raid.01 raid.02
raid / --level=1 --device=md1 raid.11 raid.12
raid /data --level=1 --device=md2 raid.21 raid.22

Comment 3 Chris Lumens 2007-03-26 14:38:49 UTC

*** This bug has been marked as a duplicate of 215231 ***