Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231994

Summary: Evolution hangs when attempting to send signed mail
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: evolution-data-serverAssignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: peter
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: evolution-data-server-1.10.0-2.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-15 04:05:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150226    

Description David Nielsen 2007-03-13 14:36:40 UTC
Description of problem:
When sending a signed mail Evolution hangs before even prompting for the
password. Unselecting the option to sign mail works around the issue and mail is
send off correctly.

Version-Release number of selected component (if applicable):
evolution-2.9.92-1.fc7
evolution-data-server-1.9.92-4.fc7
gnupg-1.4.7-3

How reproducible:
100%

Steps to Reproduce:
1. Setup account (mine is IMAP if it matters) 
2. Setup gpg signature
3. Attempt to send mail which is signed
  
Actual results:
Impressive hang

Expected results:
Glorious signed mail send off to the world.

Additional info:
CC'ed Peter Gordon since he also experiences this.

Comment 1 Saikat Guha 2007-03-14 16:23:24 UTC
Confirming. Refer to http://bugzilla.gnome.org/show_bug.cgi?id=418255 
for debug output and stacktrace.

Comment 2 Matthew Barnes 2007-03-14 21:05:39 UTC
I found the cause of this bug; it's basically a threading deadlock.  Easy fix.
I should have updated packages available in the next day or so.

The bug is in evolution-data-server, so changing the component.

Comment 3 Matthew Barnes 2007-03-15 04:05:29 UTC
Should be fixed in evolution-data-server-1.10.0-2.fc7.

Feel free to reopen this bug if the problem still occurs.

Comment 4 Saikat Guha 2007-03-16 05:26:52 UTC
Seems to be fixed in rawhide.

evolution-data-server-1.10.0-2.fc7.i386
evolution-2.10.0-2.fc7.x86_64
evolution-data-server-devel-1.10.0-2.fc7.x86_64
evolution-data-server-1.10.0-2.fc7.x86_64


Comment 5 Peter Gordon 2007-03-17 00:15:40 UTC
Just confirming Saikat's comment; it's fixed for me too. Thanks, Matthew! :]