Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 231900

Summary: obsoletes handling doesn't account for arch
Product: [Fedora] Fedora Reporter: Nalin Dahyabhai <nalin>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-25 19:24:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150226    

Description Nalin Dahyabhai 2007-03-12 21:04:19 UTC
Attempting to update to a recent Raw Hide snapshot, I see this:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 nautilus-sendto         i386       0.10-1.fc7       development        79 k
     replacing  nautilus-sendto-bluetooth.x86_64 0.8-4.fc7

 nautilus-sendto         x86_64     0.10-1.fc7       development        82 k
     replacing  nautilus-sendto-bluetooth.x86_64 0.8-4.fc7

I don't have the i386 nautilus-sendto-bluetooth installed, so installing the
i386 nautilus-sendto seems kinda wrong.

Comment 1 Jeremy Katz 2007-03-19 22:00:29 UTC
This has come up before and I think the actual behavior has flip-flopped over
time...  given that the obsolete doesn't specify an arch (it can't really), what
the "right" thing to do is hard to say.  By installing both arches, it's
consistent with if you just did the install... but not with an update.  I guess
it probably makes more sense to follow the update path.

Comment 2 Jeremy Katz 2007-04-25 19:24:36 UTC

*** This bug has been marked as a duplicate of 200643 ***